• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

XML Validation Error

 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have the following XSD files:



The test.xsd that I'm importing is:



Now when I want to validate the following XML:



I get the following error:



Any ideas as to how I could resolve this error?
 
g tsuji
Ranch Hand
Posts: 669
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In test.xsd,

should be read
 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That did not solve the problem either. I corrected it and still I face the same error! Do I have to pass both the XSD files in my validation routine?
 
g tsuji
Ranch Hand
Posts: 669
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Your xml itself is incorrect:

should obviously read
 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I modified my XML, but still face the same error!
 
g tsuji
Ranch Hand
Posts: 669
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have nothing to say on what I don't see. Goodbye.
 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem was with loading the Schema files and I do not see a reason as to why it should fail. I modified the bit where I load the XSD file to also load the imported XSD and then it seems to be fine!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic