• Post Reply Bookmark Topic Watch Topic
  • New Topic

No backword competible problem when using jboss  RSS feed

 
sam liya
Ranch Hand
Posts: 1274
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I compile my web application using 1.7 java. Then i try to run it on Jboss server which support java 1.6.it gives me error.does that mean Java doesn't support backword competible?
 
Maneesh Godbole
Bartender
Posts: 11445
18
Android Eclipse IDE Google Web Toolkit Java Mac Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sam liyanage wrote:I compile my web application using 1.7 java. Then i try to run it on Jboss server which support java 1.6.it gives me error.does that mean Java doesn't support backword competible?

That is not what backward compatible means. The correct 'definition' of backward compatible is compile on a lesser version (e.g. 1.6) and run on higher version (e.g. 1.7). In other words a higher version can run earlier (or backward) versions

Moving to a more appropriate forum as this is not JBoss related
 
Campbell Ritchie
Marshal
Posts: 56529
172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you find the documentation for the javac tool, you find you can compile code to be compatible with earlier versions.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!