This week's book giveaway is in the Reactive Progamming forum.
We're giving away four copies of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams and have Adam Davis on-line!
See this thread for details.
Win a copy of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams this week in the Reactive Progamming forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

Unable to find a java Virtual machine in SQL Developer In Oracle

 
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there

recently I have download for Oracle Database for Windows-32 bit.And I am using Windows 64.

When i click on sqldeveloperW.exe then it will show an error that "Unable to find Java Virtual Machine.To point to a location of Java Virtual Machine ..."

Is there any way that this thing can sort out Or I need to download Its 64 bit version?


Thanks
 
Bartender
Posts: 3648
16
Mac OS X Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't think this a 32 vs 64 bit issue. I'm sure you can use 32-bit DB on 64-bit OS.

When SQL Developer prompt for that java thing, browse to the "java.exe" in the JDK folder. The runtime's java.exe would not work.

If your computer doesn't have the JDK then install it.
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks

But Now it is not asking any prompt.


How can i manually configure this to work?


Any file edit?


 
K. Tsang
Bartender
Posts: 3648
16
Mac OS X Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Reinstall it? If the prompt is gone, does that mean you are able to use it (eg connect to DB etc)?
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just simple download Oracle database
Burned into disc
install it from there

How to use oracle database?
Is there link that will guide step by step how to use Oracle Db?
 
Rancher
Posts: 1090
14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not sure this is your problem, but we can try.

Go to the directory where you've installed your sqldeveloper client.

Go to the bin folder and in the bin folder go to the sqldeveloper.conf file and edit it.

Add the path to JavaHome in that file.

The file I have on my laptop looks like this--

IncludeConfFile ../../ide/bin/ide.conf

AddVMOption -Dapple.laf.useScreenMenuBar=true
AddVMOption -Dcom.apple.mrj.application.apple.menu.about.name="SQL_Developer"
AddVMOption -Dcom.apple.mrj.application.growbox.intrudes=false
AddVMOption -Dcom.apple.macos.smallTabs=true
AddVMOption -Doracle.ide.util.AddinPolicyUtils.OVERRIDE_FLAG=true

AddVMOption -Dsun.java2d.ddoffscreen=false

AddVMOption -Dwindows.shell.font.languages=

AddVMOption -XX:MaxPermSize=128M


IncludeConfFile sqldeveloper-nondebug.conf

SetJavaHome C:\Program Files (x86)\Java\jdk1.6.0_45



You need to add the path of where you have installed the JDK for the 32 bit Windows. And see if it works.
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
But I have Install 64 bit on my Windows 64 Bit OS.

Will 32 bit will not work on 64 bit system?
 
Chan Ag
Rancher
Posts: 1090
14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not too sure. You can try giving the path of the 64 bit JDK directory and see if it works.

For me it didn't work but the IT admin guy at my workplace said I've got to install the 32 bit JDK and give the path of that in the conf file.
I also have a 64 bit OS.
After I did that, the sql developer client started working for me.

I don't know the root cause of the issue. I guess my fix is a workaround that worked on my machine. I am not even sure you have the same issue.

 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes now Sqlplus is working from command prompt but not from GUI?


When i Click on "SqldeveloperW.exe) it shows same error that i mentioned above
 
Chan Ag
Rancher
Posts: 1090
14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oh yes, download the JRE6 also for a 32 bit installation and give that path when prompted to locate the Java.exe.

I put the jre6 in the following directory.

\Program Files(x86)/Java

Let us know if it worked.



 
Chan Ag
Rancher
Posts: 1090
14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This page has a discussion on a similar issue. Perhaps you might want to go through it.
 
Chan Ag
Rancher
Posts: 1090
14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I know of only this workaround. Sorry.

If it doesn't work then you might want to reinstall the Oracle db and then give the correct path when prompted for them.
 
Chan Ag
Rancher
Posts: 1090
14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Chan Ag wrote:Oh yes, download the JRE6 also for a 32 bit installation and give that path when prompted to locate the Java.exe.

I put the jre6 in the following directory.

\Program Files(x86)/Java

Let us know if it worked.



Actually that is wrong. If you installed the JDK like I said, and not the SDK, then you have the JRE already. You don't need to install it again.
I didn't realize that while I was fixing this issue on my machine, I had first installed only the JRE cause the error said Java.exe was needed and I was talking about JDK all the time, not SDK.

So if after installing the JDK for a 32 bit installation and setting the Java home path in the conf file, it is still not working, manual property change that worked for me isn't working for you.
Sorry.
 
We don't have time for this. We've gotta save the moon! Or check this out:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!