Win a copy of Java EE 8 High Performance this week in the Java/Jakarta EE forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem downloading a file from a JEE application running on a Tomcat Server  RSS feed

Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to download an Excel file from a Tomcat 7 server. Everything worked fine until about 2 weeks ago. At that time, the download started hanging in IE (IE11). The download also worked and still works in Chrome. After a timeout, I get the following exception:

at org.apache.catalina.connector.OutputBuffer.doFlush(
at org.apache.catalina.connector.OutputBuffer.flush(
at org.apache.catalina.connector.CoyoteOutputStream.flush(
at com.firstmanhattan.admin.model.PoiSpreadSheet.sendFile(
at com.firstmanhattan.admin.actions.BondDurationAction.perform(
at com.firstmanhattan.servlet.FMCController.doPost(
at javax.servlet.http.HttpServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at org.apache.catalina.valves.AccessLogValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.http11.AbstractHttp11Processor.process(
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)
Caused by:
at org.apache.coyote.http11.InternalAprOutputBuffer.flushBuffer(
at org.apache.coyote.http11.InternalAprOutputBuffer.flush(
at org.apache.coyote.http11.AbstractHttp11Processor.action(
at org.apache.coyote.Response.action(
at org.apache.catalina.connector.OutputBuffer.doFlush(
... 24 more

The code is as follows:

On Chrome, the write loop prints 26 reads of 4096 bytes and one of 2048 (totals 108544, the correct file size). On IE, the loop prints 9 reads of 4096 bytes and then hangs. It eventually times out throwing the above exception.

Any ideas?
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!