• Post Reply Bookmark Topic Watch Topic
  • New Topic

Getting "Error parsing WSDL" from ant codegen task.

 
William Barnes
Ranch Hand
Posts: 1001
Eclipse IDE Firefox Browser Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Wow, I haven't posted here for years! Guess I never got away from Java.

This post is mainly another way of forcing myself to look at this problem again, from another angle. And if anyone has any helpful tips that would be great.

Same error using Eclipse & RAD, on two different machines. None of my coworkers have any issues with this code. Main build.xml calls another build.xml which builds "common" code. The WSDL in question is created successfully, but when it is used am getting the error. Have compared generated WSDL file to a coworkers, and see no differences. Disabled all Validation for the workspace (Windows --> Validation --> Select Suspend all validators, Unselect Allow projects to override). Make the workspace writeable. Since this is the "common" code base, it is only built once when you create your workspace, and as my coworkers never had this issue they knew very little about the error.

Update - swapped out the WSDL file, with one from a coworker, and got the same error. So the problem has something to do with the codegen task. Trying to figure out which version of ant is being used.

Lots more details, which I can add as people have questions.

Thanks.

 
William Barnes
Ranch Hand
Posts: 1001
Eclipse IDE Firefox Browser Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Figured it out finally. AntCodegenTask doesn't support paths with spaces. You can't use paths which contain spaces, with AntCodegenTask. If you are using AndCodegenTask, make sure the path you are using doesn't contain any spaces.


 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!