• Post Reply Bookmark Topic Watch Topic
  • New Topic

JAX-WS XML input parameter being escaped  RSS feed

 
Asad Imtiaz
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello folks

I have an issue which i can seem to get my head around. I have a webservice for which I am writing a client. It has just one method "send" that takes a input as xml. It works find in SOAP UI but once I invoke the WS through code it keeps giving me the following error



To validate whether the right SOAP is being generated I fired up wireshark and found out that the XML input parameter was being escaped. The SOAP looks as follows. I am posting a screenshot as the post unescapes it again.





As you can see that the XML tags have been escaped. Following is working SOAP from SOAP UI



Following are other artifacts to make this work. The WSDL




The code I am using



the Client Class



I also created a SOAPHandler to see if the message has been escaped but i get the correct unescaped xml in the handler class





at the moment I am using Java 6 update 6.

Any pointers will be appreciated. Thanks


Regards
 
Varun Agrawal
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I am having this same issue where the xml that needs to be sent is being escaped. Have you found a solution for this? I have been looking around for quite some time and have not gotten anything to work. Could you please post the solution if you've found it.

Thank You
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!