• Post Reply Bookmark Topic Watch Topic
  • New Topic

Embedded browser localhost issue  RSS feed

 
Greenhorn
Posts: 19
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a Windows GUI developed using Eclipse EE on Windows 7.

I'm trying to stick to SWT.

I have an embedded browser as follows:




It is used to connect to 127.0.0.1:6500

A C program listens on 6500, and in response displays a simple form. The C program is extensively used and rarely fails when using any external browser. The port 6500 is clear for use by the C program.

However the Java embedded browser often does not receive the form, sometimes receives it and it works for a while, then goes to sleep, or sometimes works for 5 or 6 interactions which meets the test need. Doesn't seem connected with time. I can use it slowly for 3 interations and it fails. I can use it very quickly and it will often fail quickly. So doesn't appear to be a simple time out.

I've tried to find a resolution but to no avail. For sure the problem relates to the connection to the C program on local host but as I can't get at it and the C program never fails with any other browser I'm a bit stuck.

I can say the embedded browser can get say BBC.com reliably over a considerable time period. So as an internet browser the embedded browser is fine.

But I cannot get held up on this so unlewss anyone has any thoughts I want to change to a different embedded browser. Can anyone suggest a possible? Many tx in anticipation.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!