• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

Problem configuring Spring WebFlow, Spring Boot + Thymeleaf

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,

I'm trying to integrate SWF into an existing project that uses both Spring Boot and Thymeleaf but am currently encountering the following error when trying to navigate away from the first page in my flow - I expect because it's not actually picking up and using the flow:

2014-11-21 09:12:10.032 WARN 3725 --- [nio-8080-exec-5] o.s.web.servlet.PageNotFound : No mapping found for HTTP request with URI [/payments/checkout-widget/session/resources/js/bootstrap.min.js] in DispatcherServlet with name 'dispatcherServlet'
2014-11-21 09:12:10.198 WARN 3725 --- [io-8080-exec-10] o.s.web.servlet.PageNotFound : No mapping found for HTTP request with URI [/favicon.ico] in DispatcherServlet with name 'dispatcherServlet'
2014-11-21 09:12:13.868 WARN 3725 --- [nio-8080-exec-1] o.s.web.servlet.PageNotFound : No mapping found for HTTP request with URI [/payments/checkout-widget/session/1/funding-instruments] in DispatcherServlet with name 'dispatcherServlet'


The structure of my project is shown below along with (what I hope are) the relevant classes. After spending a good couple of days Googling and trying out different things, I still feel that I'm no closer to working out what's wrong. I initially I tried to instantiate my own AjaxThymeleafViewResolver - but from what I understand this shouldn't be necessary, as there should be one automatically created by Spring - and indeed it was working perfectly fine without one before I started to add SWF into the mix. I also tried to add a SimpleUrlHandlerMapping but this also made no difference and I get the same error. I'm sure I'm missing something somewhere in the config that would make it all click into place - any pointers in the right direction would be very much appreciated :-) If there's any details I've missed off that would help please ask.

Many thanks in advance,

Ian



MvcConfig.java

WebflowConfig.java

webflow.xml

CheckoutWidgetSessionMvcController.java:

payment-methods.html:
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic