• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

2.7" API12/13 Emulator problem?

 
john johns
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there,

Fairly new to android programming. I'm not sure if this is a problem on my end, or a problem with the emulator. When I load up the 2.7in emulator in either API12 or API13, the whole screen seems blown up. This problem begins immediately. I've attached a screenshot to compare the problem with the norm. As you can see, it seems stretched out, both at the start and when I load my app.

Extra note:
I haven't tested it on everything yet, but here's what I found.

For 2.7in, so far, it seems to only be a problem with API12/13. API 8/10/11//21
When working with API 12, the problem only exists in the 2.7" and the 2.7"slider. Every other device seems fine.

I've tried to search for answers to this problem, but haven't found any. Any ideas would be appreciated.
1.jpg
[Thumbnail for 1.jpg]
Screenshot
 
Ulf Dittmer
Rancher
Posts: 42969
73
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I advise to spend zero time debugging problems with API levels < 15 in the emulator. If your project is important enough to need to support API levels lower than that, then it can afford to buy devices that run those API levels.
 
john johns
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the info. That's disappointing, but I suppose there's nothing I can do.

Also, I'm also a little bit confused as to using AndroidAPI vs GoogleAPI. For some reason, in certain devices, the emulator will not work(Emulator permanently stuck on Android loading screen) when I use AndroidAPI, but works just fine with GoogleAPI. Is this something I should also ignore or is there something critical I'm not understanding?
 
Ulf Dittmer
Rancher
Posts: 42969
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've seen that happen time and again; my solution is to quit the emulator and restart it - eventually it will work. I don't know that there's a connection to Google APIs being installed vs. not so, but I haven't looked into what might cause the issue (which is to say, I'm ignoring the problem).
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic