• Post Reply Bookmark Topic Watch Topic
  • New Topic

incompatible types

 
Michael Piaser
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am receiving the error below which I don't know what to do about. Line 67 is the line which starts "Query query3". I copied this code from another part of the program (9,000 files) and it is fine there.

:\VOX\voxware-1.1.12\voxware\voxware-impl\src\main\java\com\voxware\impl\wem\WemUserRepository.java:[67,44] error: incompatible types
[ERROR]
[ERROR] could not parse error message: required: Query
[ERROR] found: SQLQuery

 
E Armitage
Rancher
Posts: 989
9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check that the imports you have where you copied the code from are the same as you have where you copied the code to.
 
Michael Piaser
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I solve this problem by:
1) Closing every open java file in Eclipse
2) Running a Eclipse clean operation
3) From a DOS prompt, running a Maven clean operation
4) Launching Eclipse
5) Opening my Java program

Strange, but once I did these things, everything started working as I expected.
 
No, tomorrow we rule the world! With this tiny ad:
the new thread boost feature brings a LOT of attention to your favorite threads
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!