• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can you resolve this Java error?

 
Florian Dushniku
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I get this error http://screencast.com/t/TrMH9E3K6 when I try to run the MeetingBurner desktop sharing app.

I have tried everything mentioned on web and MeetingBurner support team in the end told me to look for help regarding Java.

Please let me know if anyone can help me resolve this?

Thanks,
Flori
 
Tim Cooke
Sheriff
Pie
Posts: 3203
142
Clojure IntelliJ IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Florian, and welcome to the Ranch!

Please can you post the error message you are getting. I am not willing to click a random link in a post, and I suspect others will feel the same. So to get the best help, I recommend you make it as easy as possible for us to understand the issue you are facing.

Florian Dushniku wrote:I have tried everything mentioned on web

Everything? You must have been working on this for some years.... ;)
 
Florian Dushniku
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tim,

Thanks a lot for your reply.

OK, MeetingBurner want me to run a jnlp file. I run it and get a window like this:

Application Error
Unable to launch the application.
Name: MeetingBurner
Publisher: MeetingBurner
Location: http://www.meetingburner.com

and then 2 buttons:
Ok and Details:

When I click on details another window is shown:

More Information
Error: java.lang.unsatisfiedlinkerror: org.bridj.platform.sizeof_ptrdiff_t()I

Under this error there are 2 tabs:

Launch File tab contains:


<jnlp spec="1.0+" version="2.7.2" codebase="http://www.meetingburner.com/jnlp">
<information>
<title>MeetingBurner</title>
<vendor>MeetingBurner</vendor>
<homepage href="docs/help.html"/>
<description>MeetingBurner sharing application.</description>
<description kind="short">Sharing Application</description>
<icon href="mbnice.png" width="64" height="64"/>
<offline-allowed/>
</information>
<security>
<all-permissions/>
</security>
<update check="always" policy="always"/>
<resources>
<j2se version="1.6+" initial-heap-size="64m" max-heap-size="448m" href="http://java.sun.com/products/autodl/j2se"/>
<jar href="http://www.meetingburner.com/jnlp/networxonline-desktop-publisher-0.5.98-win.jar"/>
<jar href="http://www.meetingburner.com/jnlp/bridj-0.7-120315.jar"/>
<jar href="http://www.meetingburner.com/jnlp/networxonline-na-0.6.1.jar"/>
<jar href="http://www.meetingburner.com/jnlp/juv-rtmp-client-1.9.2.jar"/>
</resources>
<application-desc main-class="com.networxonline.dp.AppDesktopPublisherBridJ">
<argument>-view.control.title</argument>
<argument>MeetingBurner</argument>
<argument>-url.stream</argument>
<argument>rtmp://westcoast.meetingburner.com:443/live/MMKZ2YV3_501701/4702124429168165232</argument>
<argument>-view.control.showPreview</argument>
<argument>yes</argument>
<argument>-video.pauseIfWindowInactive</argument>
<argument>no</argument>
<argument>-video.codec</argument>
<argument>svc</argument>
<argument>-view.control.showMinimizeWhenSharing</argument>
<argument>no</argument>
<argument>-view.control.minimizeWhenSharing</argument>
<argument>no</argument>
<argument>-connection.maxUploadBandwidth</argument>
<argument>850000</argument>
<argument>-connection.useSystemProxy</argument>
<argument>no</argument>
<argument>-connection.reconnectionTimeout</argument>
<argument>6000</argument>
<argument>-video.frameRate</argument>
<argument>5</argument>
<argument>-callback.heartbeat</argument>
<argument>no_check</argument>
<argument>-video.keyFramePeriod</argument>
<argument>-1</argument>
<argument>-video.inactiveTopmostWindowColor</argument>
<argument>#b6b6b6</argument>
<argument>-connection.adjustMaxUploadBandwidth</argument>
<argument>no</argument>
<argument>-connection.parameter</argument>
<argument>4702124429168165232</argument>
<argument>-mouse.frameRate</argument>
<argument>20</argument>
<argument>-svc2.maxFrameSize</argument>
<argument>-1</argument>
<argument>-svc2.blockSize</argument>
<argument>64x64</argument>
<argument>-svc2.deflaterLevel</argument>
<argument>4</argument>
<argument>-svc2.quality</argument>
<argument>3</argument>
<argument>-method.requestVideoKeyFrame</argument>
<argument>sendmethekey</argument>
<argument>-method.stopPublishing</argument>
<argument>stopit</argument>
<argument>-method.startPublishing</argument>
<argument>startit</argument>
</application-desc>
</jnlp>

Exception tab contains:

java.lang.UnsatisfiedLinkError: org.bridj.Platform.sizeOf_ptrdiff_t()I
at org.bridj.Platform.sizeOf_ptrdiff_t(Native Method)
at org.bridj.Platform.<clinit>(Platform.java:149)
at org.bridj.CRuntime.<clinit>(CRuntime.java:450)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at org.bridj.BridJ.getRuntimeByRuntimeClass(BridJ.java:233)
at org.bridj.BridJ.getRuntime(BridJ.java:264)
at org.bridj.BridJ.getTypeInfo(BridJ.java:309)
at org.bridj.BridJ.initialize(BridJ.java:924)
at org.bridj.NativeObject.<init>(NativeObject.java:23)
at org.bridj.Callback.<init>(Callback.java:25)
at com.networxonline.dp.na.bridj.win.callback.EnumWindowsProc.<init>(Unknown Source)
at com.networxonline.dp.na.bridj.win.WinWindowManager$EnumWindowsProcImpl.<init>(Unknown Source)
at com.networxonline.dp.na.bridj.win.WinWindowManager.getWindows(Unknown Source)
at com.networxonline.dp.support.BridJWindowManager.getWindows(Unknown Source)
at com.networxonline.dp.support.DesktopPublisherModel.<init>(Unknown Source)
at com.networxonline.dp.AppDesktopPublisher.main(Unknown Source)
at com.networxonline.dp.AppDesktopPublisher.main(Unknown Source)
at com.networxonline.dp.AppDesktopPublisherBridJ.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Unknown Source)
at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Lol, in fact I have been trying for some days to resolve this.

I am using Windows 8.1 Pro
Firefox 35.0.1 but the same error appears on every browser I have tried on this PC (Chrome, Opera, Internet Explorer)
Java Version 8U31

When I try this from another PC from the same home network it works, but I want to make it work on on my PC that is currently showing this error.

I hope I can find the solution here.

Thanks a lot,
Flori
 
Paul Clapham
Sheriff
Posts: 21554
33
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you asked the people at MeetingBurner about this problem?
 
Florian Dushniku
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes. They guided me to some solutions but nothing worked. In the end they told me to look for help relatef to java.
 
Florian Dushniku
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was able to resolve the error and I hope the solution will help anyone else in the future.

The problem was related to the temp folder. The app was trying to run a fole from the temp folder but coulden't because there was an Access Denied error to run files from the temp folder. In fact the permissions there were set to Full for Admins and I was a user with admin rights, anyway I gave full permissions to Everyone on the temp folder.

Thanks,
Flori
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic