• Post Reply Bookmark Topic Watch Topic
  • New Topic

Getting Error while compiling  RSS feed

 
Ranch Hand
Posts: 77
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi , I am new a maven. I created an web application using maven. When I try to compile I am getting following error in command prompt. I know that I need to make changes in pom.xml but not able to find a solution.

 
Shiva Gajjala
Ranch Hand
Posts: 77
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
pom.xml is below,
 
author & internet detective
Marshal
Posts: 37896
594
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Shiva,
What version of Java are you using to run Maven? This is probably the version of Java in your path so you can go to the command line and type "javac -version".

 
Shiva Gajjala
Ranch Hand
Posts: 77
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply Jeanne Boyarsky. I already changed the java version from 1.6 to 1.7 and it was working fine . but now when I say mvn package ,build is getting failure and getting 2 errors .

I tried deleting these 2 test files manually and tried ,but I am still getting the same errors
 
Shiva Gajjala
Ranch Hand
Posts: 77
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Before I deleted wrong files. Now I deleted the 2 test files correctly ,its working fine .Thank you
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!