• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

How to change in M2E default repository? (for artifacts resolving)

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
In my company access to Maven Central is blocked. There is internal Nexus repository accessible via https (it is not Maven Central mirror)

Half of the issue with https I resolved using VM arguments (Window->Preferences->Java->Installed JRE->Edit->default VM arguments)
-Djavax.net.ssl.trustStore=h:\tools\dev\maven_ca_store\trust.jks -Djavax.net.ssl.trustStorePassword=passwd123
But this is working only for/during deployment to Nexus.

Issue is that M2E GUI seems to be unaware of https repository and it is not resolving dependencies.
Configuration attempts (Window->Preferences->Maven->Archetypes->Add Remote Catalog->Verify) with https url fail with "Remote catalog is empty". I can browse it in browser, it is not empty.
When I try url with http (another temp Nexus) it is working OK.
I tried also defining mirror in user settings.xml file with no luck.
I tried adding VM argument: -DarchetypeCatalog=https://<server>/nexus/content/groups/public with no luck.

I tried all of above with embedded and external maven (3.2.5) installation with the same result - no matter what I do GUI does not want to read dependencies from https repository.

When using maven from command line with argument:
-DarchetypeCatalog=https://<server>/nexus/content/groups/public
it is working OK.

I am using Win-32 Eclipse 4.4.0 (with included M2E 1.5.0), JRE 1.7_60, Nexus 2.9.1

Is it possible to configure M2E with only one repository (not Maven Central) accessible only via https?
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Try editing you settings.xml file and specifying a mirror. In my environment, all remote repository access goes through our Nexus server, and I use a mirror to redirect all calls to it. Example:

<mirrors>
<mirror>
<id>name-of-our-nexus-server</id>
<mirrorOf>*</mirrorOf>
<url>https://name-of-our-nexus-server/content/groups/public/</url>;
</mirror>
</mirrors>

See http://maven.apache.org/settings.html#Mirrors
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic