Win a copy of Cloud Native PatternsE this week in the Cloud forum
or Natural Language Processing in the AI/ML forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Openshift: war file disappears

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I deployed war-file to openshift via rhc and wildfly administrative console. It works fine. But after few days (approximately one week) war disappears. The administrative tool on openshift and wildfly console works correctly. Then I redeploy war and it's ok again. Is there any time limit on openshift? Any ideas what is the problem?


Looks like it restarts every week.
To deploy war I use rhc port-forward then I go to 127.6.80.1:9990 to administrative tool and upload my war on deployments tab. My war doesn't contain pom.xml or src folder but it includes WEB-INF folder with .class files.
 
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
do you have an account any paid account on openshift or you are using it as free users?
 
Sergei Semenov
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a free account.
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It might be possible that You have replaced your war file.or deleted your project on Openshift.

Create a new war file and then try to deploy it on openshift
 
Sergei Semenov
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'll try to. Should I deploy war from the specific folder for openshift or any folder?
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you say the war disappears, what exactly do you mean? Where/how are you checking that?
 
Sergei Semenov
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I wrote how exactly I deploy the war I use rhc port-forward command then I go to the administrative console -> deployments, there I deploy the war accordingly to above passage war disappears there.
 
Sergei Semenov
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Kishor Joshi wrote:It might be possible that You have replaced your war file.or deleted your project on Openshift.

Create a new war file and then try to deploy it on openshift



I rebuilt and redeployed the war nevertheless it didn't help.
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do the logs show any signs of the application being undeployed?
 
Sergei Semenov
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The log in the post is the last part of the log the other part is a regular work log - nothing suspicious. I use rhc-tail to get it. I can't understand if it was undeployed.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!