Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

SW 6F00 but applet works fine

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I need some insight about some weird behavior I'm getting.
I developed an applet for GP 2.1.1 and Java Card 2.2.1. I have 2 sets of cards from different providers but with same characteristics.
When I load the cap on one set of cards, everything works fine.
When I load the same cap on the other set of cards, everything still works, but instead of getting 90 00 from the cards, every APDU I send returns 6F00. But the applet worked as expected and I am able to continue working.

My guess is that it has something to do with the global platform API, but I'm unsure of what.

For example, first APDU I need to send to the applet is an Initialize Update (the APDU is 100% correct):

[USERCARD: Command]
80500000081810D6E7AEFA77F700
[Response]
000050540000001900020202002FDC5D12A22CB7A11051C5D96DA298
(6F00)
(328.125 ms)

6F 00, but it worked, after that I can ignore the SW and send an Ext Auth APDU and it will work also.

If I load the cap on the other cards and send the corresponding IU APDU, I will get 90 00


I really hope you can provide some insight.

This is the code:

 
    Bookmark Topic Watch Topic
  • New Topic