• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Strange Problem with log4j.xml

 
Ranch Hand
Posts: 71
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using log4j.xml in a web application , when I do the following the logs are created but the logs are not written
Stop the application server.
Add war file to deployments folder.
Start the application server.

But , when I do the following the logs are created and also logs are populated as expected.
Start the application server without any war in it.
then add the war file , it gets deployed.

My App Server - Jboss 6.3 EAP.
 
Ranch Hand
Posts: 662
Eclipse IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you check the configuration log4j.xml file is actually refreshed in the deployments folder.
Try adding a dummy commented line in log4j property or xml file and see if it getting refreshed after deployment.

BTW, what do you mean by logs are "created" and logs are "written"? What's the difference?
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!