Win a copy of Node.js Design Patterns: Design and implement production-grade Node.js applications using proven patterns and techniques this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Getting parameter is incorrect error message in jcifs-1.3.17 and jcifs-1.3.18

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
My application uses the domain controller of version 2003 for single sign-on (sso) and it is now upgraded to version 2008. Before up-gradation, I used jcifs-1.3.14 library and it was perfectly working fine for sso. Now after up-gradation I'm facing compatibility issues with the jcifs library (jcifs-1.3.14) and the domain controller verison (2008). So,I tried with jcifs-1.3.17 and jcifs-1.3.18 jars. I'm getting "the parameter is incorrect" error message during sso. Also I'm using ntlmv2 for authentication and I do not find any issues with the authentication.

I tried with different jcifs.smb properties to resolve the issue.The properties which i tried are mentioned below :




I tried with all the possible combinations. But no luck yet.Can anyone please help me to resolve my issue ....
 
That's my roommate. He's kinda weird, but he always pays his half of the rent. And he gave me this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic