This week's book giveaway is in the JavaScript forum.
We're giving away four copies of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js and have Paul Jensen on-line!
See this thread for details.
Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Beta version - broken links - issues  RSS feed

 
Srikkanth Mohanasundaram
Ranch Hand
Posts: 243
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I'm using the beta version of the site, and I want to report a couple of issues which i noticed.

  • Unwatch Topic
    Steps to reproduce
    1. Unwatch a topic.
    2. Click on the "Click Here" link to go back to topics. This link is broken


  • Post purple mooseage
    Steps to reproduce
    1. Unwatch a topic.
    2. Click on the "Click Here" link to go back to inbox. This link is broken


  • Thanks
    Srikkanth
     
    Devaka Cooray
    Marshal
    Posts: 5511
    687
    Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Hi Srikkanth,

    Thank you for providing us with your feedback on beta pages. That would hopefully help us a lot in moving forward quickly.

    It's also great the you reported them in a really helpful way, that with instructions on how to reproduce. But unfortunately, I am unable reproduce the bugs you outlined.

    When I click the "Stop Watching" button, I get a message similar to you mentioned, but the "click here" link was fine for me. Can you perhaps show me the URL of a broken link you have gotten? I also couldn't go well through the steps on "Post Purple Moosages", in which you seem to have entered the same steps as of the first one by mistake??
     
    Srikkanth Mohanasundaram
    Ranch Hand
    Posts: 243
    1
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Hi Devaka,

    I'm attaching some screenshots here.

    Thanks
    Srikkanth
    Screen-Shot-2015-05-11-at-6.27.03-AM.png
    [Thumbnail for Screen-Shot-2015-05-11-at-6.27.03-AM.png]
    Unwatch topic
    Screen-Shot-2015-05-11-at-6.28.37-AM.png
    [Thumbnail for Screen-Shot-2015-05-11-at-6.28.37-AM.png]
    Broken link - misses /forums in the URL
     
    Devaka Cooray
    Marshal
    Posts: 5511
    687
    Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Well that helped, thanks.
    We will push a fix to the production with our next deployment.

    Do you see a broken link purple moosages as well?
     
    Srikkanth Mohanasundaram
    Ranch Hand
    Posts: 243
    1
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Yes. Here are the screenshots

    -- Srikkanth
    Screen-Shot-2015-05-12-at-8.47.33-PM.png
    [Thumbnail for Screen-Shot-2015-05-12-at-8.47.33-PM.png]
    Screen-Shot-2015-05-12-at-8.47.46-PM.png
    [Thumbnail for Screen-Shot-2015-05-12-at-8.47.46-PM.png]
     
    Devaka Cooray
    Marshal
    Posts: 5511
    687
    Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Fixed, and this too will go live with our next deployment.
    Thank you for reporting these bugs, Srikkanth!
     
    Srikkanth Mohanasundaram
    Ranch Hand
    Posts: 243
    1
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Thank you Devaka. There's more thing which i noticed last night. I think this again could be an one-off issue, but reporting it anyways.

    This topic is in the HTML,CSS,Javascript forums. The forum listing shows that there are 3 posts and the last post is by Luke Zechariah. But when i click and open the topic the last reply was by Bear ( and there are 3 posts only ). I think the post by this person was removed by the moderator or something but listing page somehow still pulls the name.

    Screenshots attached.

    Topic ID : 649610

    Edited to include topic id.


    Thanks
    Srikkanth


    Screen-Shot-2015-05-13-at-8.31.03-PM.png
    [Thumbnail for Screen-Shot-2015-05-13-at-8.31.03-PM.png]
    Screen-Shot-2015-05-13-at-8.35.30-PM.png
    [Thumbnail for Screen-Shot-2015-05-13-at-8.35.30-PM.png]
     
    Devaka Cooray
    Marshal
    Posts: 5511
    687
    Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Hmm that seems to be a different bug. Thank you for reporting it, I'll look into see what I can do on that.
     
    Srikkanth Mohanasundaram
    Ranch Hand
    Posts: 243
    1
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Hi Devaka,

    Another issue which i noticed.
    Steps to reproduce
    1. Click on a user's profile.
    2. Go to the users posts.
    3. Try to filter the user's posts by a forum.
    4. The link is broken ( http://coderanch.com/posts/listByUser/-1/0/{userId} instead of http://coderanch.com/forums/posts/listByUser/-1/0/{userId} )

    If you want i can add some screenshots later tonight.

    -- Srikkanth
     
    Devaka Cooray
    Marshal
    Posts: 5511
    687
    Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    That happens only in the beta view, right?
    Will look into this.
     
    Srikkanth Mohanasundaram
    Ranch Hand
    Posts: 243
    1
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Yes, beta.
     
    • Post Reply Bookmark Topic Watch Topic
    • New Topic
    Boost this thread!