Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can't see virtual device

 
Anton Sotnikov
Ranch Hand
Posts: 59
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello everyone!
I am using Eclipse Mars with Android SDK but for my unfortunately i can't start or load device.
I do:




Red mark talking that: An Android Virtual Device that failed to load. Click 'Details' to see the error.

But i didn't see additional information into details form and into console.

Who did have same problem?

What's wrong ?

Thank you!

 
David Griffiths
Author
Ranch Hand
Posts: 45
5
Android Python Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you restarted the adb? From the command line:

adb kill-server
adb start-server

It might not be the underlying cause in this case, but it's worth trying, just in case the Android debug bridge has got into a weird state. If this happens, you won't be able to connect to any device.

The adb command is typically in your Android/sdk/platform-tools directory.
 
Anton Sotnikov
Ranch Hand
Posts: 59
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i do:
adb kill-server/start-server


and changes is nothing.


 
David Griffiths
Author
Ranch Hand
Posts: 45
5
Android Python Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What happens if you try to start the emulator from the command line with the "emulator" command? For example, o the Mac:

~/Library/Android/sdk/tools/emulator -avd 800_10

(Obviously you will need to replace the path to the 'emulator' command to match your machine).

If it doesn't start, you should get more information in the terminal window.

If it does start, it should appear in the list of devices with:

adb devices
 
Anton Sotnikov
Ranch Hand
Posts: 59
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

 
David Griffiths
Author
Ranch Hand
Posts: 45
5
Android Python Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That really sounds like a problem with the emulator binary.

Might it be the same as this problem?

http://android.phonesdevelopers.com/310_12772951/

 
Anton Sotnikov
Ranch Hand
Posts: 59
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, thank youDavid for your reply, but i decided a problem only when i run ADV for more last version mac os 10.9.3 and it normaly executed.
indeed my lion 10.7.5 is not working equipment. Please didn't repeat my mistake - work only lastest version of software and save your time.

 
David Griffiths
Author
Ranch Hand
Posts: 45
5
Android Python Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That would make sense. The binary had probably built against a different SDK level.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic