This week's book giveaway is in the Other Languages forum.
We're giving away four copies of Functional Reactive Programming and have Stephen Blackheath and Anthony Jones on-line!
See this thread for details.
Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

how to run a servlet using Weblogic 6.1?

 
Shashi Kanta
Ranch Hand
Posts: 89
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
How do i run a servlet using Weblogic 6.1?
i have foolwed the instructions given at the url:
http://e-docs.bea.com/wls/docs61/quickstart/quick_start.html
i'm able to run html and jsp files, by simply following the instructions given for each.
but, i'm not able to do so in the case for servlet.
if i want to run a servlet whose class file "HelloWorldServlet.class" has been copied into the path:
WL_HOME\config\mydomain\applications\DefaultWebApp\WEB-INF\classes
using the url
http://localhost:7001/HelloWorldServlet
what url-pattern value should i give in the web.xml file?
I would appreciate if anyone could help me on this.
thanks
rgds,
Shashi
 
Rahul Mahindrakar
Ranch Hand
Posts: 1869
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Something like the one above
 
Shashi Kanta
Ranch Hand
Posts: 89
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi rahul,
thnx for your time!
before itself, i had done all that what u had told me !
u know where my mistake was?!!
i had copied the class file from the directory WL_HOME\samples\examples\servlets !!!
and the HellowWorldServlet had a package examples.servlets !!!
so i had to specify that for the <servlet-class> element!! like u mentioned
thnx for your time, once agn!!
rgds
Shashi
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic