Win a copy of Succeeding with AI this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
  • Junilu Lacar
Sheriffs:
  • Tim Cooke
  • Jeanne Boyarsky
  • Knute Snortum
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • salvin francis
  • fred rosenberger
  • Frits Walraven

Oracle thin driver

 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
has any body tried to set connection pool using Oracle thin driver.What should be the setting for classpath,path etc.. to do so.

Thanks a lot
pete
 
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, you can use the util.dbping utilitary to help you to get it, to do so navigate to %wl_home%\config\%domain_name% using a console window and run the script setEnv.cmd than you can use:
, if everything goes well you can use the sample codes to configure the connection pool.
regards.
[ June 20, 2002: Message edited by: Marcos Maia ]
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,
1. Add the path to "classes12.zip" (/weblogic/ext/jdbc/classes12.zip) in your WEBLOGICCLASSPATH
2. Add this to your weblogic.properties file
weblogic.jdbc.connectionPool.my_pool_name=\
url=jdbc racle:thin:@my_oracle_server:1521:my_oracle_alias,\
driver=oracle.jdbc.driver.OracleDriver,\
initialCapacity=5,\
maxCapacity=10,\
capacityIncrement=2,\
props=user=my_oracle_user;password=my_oracle_password
weblogic.allow.reserve.weblogic.jdbc.connectionPool.my_pool_name=everyone
weblogic.jdbc.TXDataSource.jdbc.my_pool_name=my_pool_name
3. Restart your weblogic.
Hope it will help you.
 
    Bookmark Topic Watch Topic
  • New Topic