• Post Reply Bookmark Topic Watch Topic
  • New Topic

.War Works to deploy on Windows but fails to deploy on a Linux server (Tomcat 7)  RSS feed

 
Goran Stepanovic
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As title introduced, the .War file I'm trying to deploy by using Tomcat 7 is not working on a machine running Linux. It does work on Windows and is of course deployed with Tomcat 7.

I've tried to track down the issue alone & searched for related problems on the web including this forum with no success so far. That is why i created this thread asking for help / hints.

The error message I tracked down are the following:

 
Campbell Ritchie
Marshal
Posts: 56541
172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch

Don't know, I am afraid. I shall duplicate your question in the Tomcat forum in the hope of getting you more attention.
 
Andrew Polansky
Ranch Hand
Posts: 310
18
Linux MS IE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you use the same Java version on your Linux box as on the Windows box? Most of the problems that I encountered during moving applications from one box to another were related to different Java versions installed on the boxes.
 
Tim Holloway
Saloon Keeper
Posts: 18795
74
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the JavaRanch, Goran!

This is a message I've never seen before. It looks like your copy of Tomcat may be damaged, so you might want to try re-installing it. Also make sure that you have enough disk space and RAM to run it.

There's a small chance that some sort of bug in the webapp or its deployment descriptor is at fault, but I think more likely that you just have a bad Tomcat.

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!