• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSF Tag not Working in Linux  RSS feed

 
Aziz Ajmeri
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have hosted my webapplication in shared tomcat on linux machine(Tomcat 7 and JDK 7)
It was working fine in my machine since I have windows in my machine , but in live environment(Linux) jsf tags are not working
My mapping of url in web.xml is perfect .
Can any one help me , why this happening and how to come out of this.
below is my web.xml


 
Tim Holloway
Bartender
Posts: 18715
71
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm afraid that without more information we cannot help. The only time in nearly 10 years of running JSF on Linux that the JSF tags didn't work was when my web.xml wasn't perfect.
 
Aziz Ajmeri
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Attached is directory structure of my web application in cpanel, Is it in right order.Even JSTL tags are also not working
screenshot.png
[Thumbnail for screenshot.png]
 
Aziz Ajmeri
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tim Holloway Thanks for your kind reply I have attached my directory structure in cpanle , please let me know what other info you need . you can contact me on ajmeriaziz@gmail.com , Thanks again
 
Tim Holloway
Bartender
Posts: 18715
71
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't seen anything obviously wrong with web.xml. But your directory snapshot appears to be the project in your IDE, not the WAR that Tomcat will be running.

Also, it's probably a good idea to include a copy of the catalina.out log from when you deployed the WAR into Tomcat.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!