• Post Reply Bookmark Topic Watch Topic
  • New Topic

Legacy App needs Apple Java 1.6  RSS feed

 
David Garratt
Ranch Hand
Posts: 216
Eclipse IDE Mac Safari
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I currently have OS X Yosemite and Oracle Java 1.8 installed and I need that version for 99% of my work. I have found a particular application which needs the Apple Java 1.6 however. If I attempt to install the older version now is that going to cause a problem - i.e. become the default java for all applications ?

Thanks

Dave
 
Rodion Gork
Ranch Hand
Posts: 47
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Usually no. Different versions of java gets into different folders on your computer. The only minor annoyance can arise if newly installed one will set either PATH variable or symbolic link for "java" command to the java 1.6 folder - but you will easily discover this with "which java" command and change to appropriate value, if necessary.

It is hard to explain in more details as I do not know how do you use java for work and how it is going to be installed. Nevertheless we often have from 2 to 5 versions of java side by side for certain needs.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!