• Post Reply Bookmark Topic Watch Topic
  • New Topic

Rest doesnt shows results

 
Isaac Ferguson
Ranch Hand
Posts: 1044
3
Java Netbeans IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Iam trying an example from the internet, and it doesnt work as expected:




and this class:




When I run this URL :

it shows this: error 404

and when I type: http://localhost:8888/

It shows this:

Index of /

Any idea, please?

Regards, Isaac

 
Ron McLeod
Saloon Keeper
Posts: 1263
131
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which HTTP server are you using? Where is WebServiceRest defined?
 
Isaac Ferguson
Ranch Hand
Posts: 1044
3
Java Netbeans IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im using MAMP
 
Ron McLeod
Saloon Keeper
Posts: 1263
131
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How did you get Apache support to JEE Servlets?
 
Isaac Ferguson
Ranch Hand
Posts: 1044
3
Java Netbeans IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
MAMP contains Tomcat
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65524
105
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Isaac Ferguson wrote:MAMP contains Tomcat


No, no it doesn't.

MAMP stands for Mac OS X, Apache, MySQL, Perl/PHP/Python.

You've either finagled things into a non-standard configuration -- which is what Tim is asking about -- or you are using something else.
 
Isaac Ferguson
Ranch Hand
Posts: 1044
3
Java Netbeans IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have installed Tomcat, when I run the example described here I get the next error.


Looks like the WEB.xml is not correct but I dont find anything wrong.

Any idea, please?
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65524
105
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That path doesn't seem to match the mapping in your deployment descriptor.
 
Isaac Ferguson
Ranch Hand
Posts: 1044
3
Java Netbeans IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The path is
http://localhost:8082/WebServiceRest/restService/
and the deployment descriptor is this one:



Display name and url pattern seems to match



I have installed a new Tomcat, and try with a new port and still like that it doesnt works. Any idea?

Why it doesnt matches?
 
Isaac Ferguson
Ranch Hand
Posts: 1044
3
Java Netbeans IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have decided to download the source from the codeClient and server code from the page of the example and use Tomcat 7. When I run it in Eclipse I get the next error:



Any idea,please?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!