• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

doubts about eclipse android emulator

 
Jhon Parker
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm new to android and I still can't pass the installation part or running my first android app.
I have a doubt about eclipse emulators and AVDs, first I downloaded from the sdk manager a system image from my sdk version api 23, this image was an ARM EABI v7.

I tried to launch my hello world app with this and it worked for a moment the emulator was launched i could navigate in the virtual phone menu.

I watched my app get installed but there was a message that says something about a process it's not responding and it give the option to choose wait or stop, later I installed the intel Atomx86 image and this was the worst it give all kinds of error in the android console and the emulator was never launched.

After this, i decided to delete all my avd that i created, I deleted them in the eclipse IDE and I deleted them from the AVD folder of eclipse,

After this eclipse went crazy and started to print a loop message in logCat saying this:

09-25 20:48:39.990: I/ServiceManager(1696): Waiting for service SurfaceFlinger...
09-25 20:48:40.960: I/PGA(577): Attempting to create new SOCKET connectionn pid = 577, tid = 577
09-25 20:48:41.000: I/ServiceManager(1696): Waiting for service SurfaceFlinger...

this repeats over and over and over

Later I tried to create another AVD with ARM because it kinda worked, but now i think that my eclipse went crazy not only because the looping message in logcat but also becasue went i choose in eclispe to show the tab Devices it shows this:

emulator 5554 Online ?[4.4.2, debug]

I'm not a expert but i think that that 4.4.2 is from the firts AVD i created because i choose to run a project with that android version, but i don't know why it still there if deleted all traces of that AVD,

So later when i choose to run my project in my ARM AVD it shows in the devices tab the emulator 5556 with all the process and i think this is normal, but my problem is that in the emulator 5554 Online ?[4.4.2, debug] because when my project is launching this tab becomes crazy and it appear and disappear a process.

In resume i just want to know how to delete this emulator 5554 Online ?[4.4.2, debug and also how to stop this

09-25 20:48:39.990: I/ServiceManager(1696): Waiting for service SurfaceFlinger...
09-25 20:48:40.960: I/PGA(577): Attempting to create new SOCKET connectionn pid = 577, tid = 577
09-25 20:48:41.000: I/ServiceManager(1696): Waiting for service SurfaceFlinger...

loop messages from my logCat, that messages loops forever, i dont want to create a filter to not show it, that would be a fake solution i want to stop it for good,





 
Guillermo Ishi
Ranch Hand
Posts: 789
C++ Linux Python
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Around 2012 with Eclipse and various Android plugins I never was able to get any more going than you are. I downloaded ADT which is Eclipse already bundled with the android stuff and never had a problem. I still use that, but I think most people now use something named Android Studio or close to that. Which is supposed to be the most modern development tools.

Since you are trying for your first app, I suggest looking up an Android course on edx or coursera. They will obviously help you get the tools installed. I took one and it was fun and really eased the learning curve with android. They don't cost anything. You can teach yourself but there are some things you will probably miss.
 
Jhon Parker
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Guillermo Ishi wrote:Around 2012 with Eclipse and various Android plugins I never was able to get any more going than you are. I downloaded ADT which is Eclipse already bundled with the android stuff and never had a problem. I still use that, but I think most people now use something named Android Studio or close to that. Which is supposed to be the most modern development tools.

Since you are trying for your first app, I suggest looking up an Android course on edx or coursera. They will obviously help you get the tools installed. I took one and it was fun and really eased the learning curve with android. They don't cost anything. You can teach yourself but there are some things you will probably miss.


I follow at youtube course I installed eclipse then the adt then sdk, I follow all the steps, I already have the ARM system image emulator working in a very deficient way to make it run I need to run my application two times, but the intel atmx86 don't work at all. I need help with this bug it's explained better in this stackoverflow question but the question don't have and answer in it's 1 year old, so my best bet it's that it's not going to be answered

https://stackoverflow.com/questions/27091035/android-on-eclipse-logcat-tag-servicemanager-with-text-waiting-for-service-surfa
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic