• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Jenkins deployment into Weblogic 12c FAILING

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I have setup jenkins on my machine and deployed the war (i.e. jenkins.war) onto Weblogic 12c and able to access the jenkins url....no problem here....

Goal : want to generate the war and deploy the same war onto the Weblogic 12c server via Jenkins

I am able to generated the war for the webapplication but when It tries to deploy the same onto the Weblogic server it's failing (I have installed the 'Deploy WebLogic Plugin' @ jenkins and configured the steps)

Steps I followed are :

Step 1: Installed the 'Deploy WebLogic Plugin' (via Manage Jenkins ->Manage PlugIns) @ jenkins version is 1.633

Step 2: have configured the Maven,JDK,etc also 'WebLogic Deployment Plugin' (as shown in step2.PNG) and the "weblogic-config.xml" file content like below


Step 3: Created a job with the Subversion data, gave the pom information, and at the "Add post build actions" button selected "Deploy the artifact to any Weblogic environments" as shown in step3.PNG image

Step 4: Applied and Save the changes of Step3 and clicked on the 'Build Now' at Jenkins

Result/Output :

-Jenkins is building the war file and placing at the desired place ( with the war file at C:\Users\aa\.jenkins\workspace\mytruck\target\trucks.war')

-But when jenkins attempts to deploy the same war file onto Weblogic its resulting in exception/error, my weblogic server is up and running and am able to login to the console with the same credentials what I have mentioned to the jenkins





Also The "Weblogic deployments logs" @ Jenkins says like below
=========================================




I tried enabling tunneling also but still not able to get through the above issue, but with the same credentials i am able to login to the weblogic console

PLEASE LET ME KNOW WHAT AM I MISSING HERE

Note: The Jenkins war is deployed onto the same weblogic server and am trying to deploy the trucks.war file onto the same weblogic through Jenkins.
step3.png
[Thumbnail for step3.png]
step3
 
Sudeesh Naidu
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
step2 attachment
step2.PNG
[Thumbnail for step2.PNG]
step2
 
Sudeesh Naidu
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Please let me know if any one has any solution on this PLEASE

Am not able to think out of the box and not getting ideas, please let me know your views/clues/suggestions

thanks & appreciate for reading this post.
 
Rancher
Posts: 2759
32
Eclipse IDE Spring Tomcat Server
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The core issue is described in the exception log that you posted. SOmetimes it helps to read the exception log messages closely



You have the wrong user name password for admin user
 
Sudeesh Naidu
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello Thanks for reading my post.

Ya...I read that message and used the same credentials to login to the weblogic admin console and it works fine, But when I give the same credentials @ Jenkins it is not able to login.

Also I have enabled the tunnelling as mentioned at the error message but still it did not work... please let me know if I am missing any thing. Thanks
reply
    Bookmark Topic Watch Topic
  • New Topic