It seems like you are new to java. I would suggest to start small programs first and then grow bigger.
"getSales" isn't a good name for a class. A Class is typically a noun and is written with the first letter capitalized.
Why are most items in your code public and static ?