Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem in deploying a web application war

 
parag Chatterjee
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,
I have created a web application at the path
config/myDomain/appilications/<myWebApp>
I have created a war named myWeb.war at
config/myDomain/appilications
by using the command
jar cf myWebApp.war <myWebApp>

Using weblogic Admin Console I had deployed the war.
There is a file named index1.html in the path
<myWebApp> at deployments/web applications
I am typing
http://localhost:7001/index1.html at browser uri path
No File found error in given at the browser.
Can anybody help me how the war file will be successfully deployed and then contents of <myWebApp> will be visible on the browser.
 
Chris Mathews
Ranch Hand
Posts: 2712
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is your web application defined as the default web app? If not then you need to specify the context-root in your url.
Example:
Instead of http://localhost:7001/index1.html
Should be http://localhost:7001/<myWebApp>/index1.html
 
Yan Zhang
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I had problem deploying war file to weblogic server. I used jbuilder (tomcat 4.0) enterprise to create the war file and ftp to weblogic server (6.1)under ..../applications/ . The application is based on struts frame work . So the war file also contains all the *.jar and config files used in struts frame work.
This is my web.xml file
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<servlet>
<servlet-name>action</servlet-name>
<servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
<init-param>
<param-name>application</param-name>
<param-value>ch.thales.strutsTest1.MessageResources</param-value>
</init-param>
<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
<init-param>
<param-name>debug</param-name>
<param-value>2</param-value>
</init-param>
<init-param>
<param-name>detail</param-name>
<param-value>2</param-value>
</init-param>
<init-param>
<param-name>validate</param-name>
<param-value>true</param-value>
</init-param>
<load-on-startup>2</load-on-startup>
</servlet>
<servlet-mapping>
<servlet-name>action</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>
<taglib>
<taglib-uri>/struts-bean.tld</taglib-uri>
<taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
</taglib>
<taglib>
<taglib-uri>/struts-html.tld</taglib-uri>
<taglib-location>/WEB-INF/struts-html.tld</taglib-location>
</taglib>
<taglib>
<taglib-uri>/struts-logic.tld</taglib-uri>
<taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
</taglib>
</web-app>

when I try to access the application:
http://host ort/<applicatonName>/index.jsp I got error message:
Error 404--Not Found
From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.4.5 404 Not Found
The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.
If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.

Any suggestion is welcome!
thanks in advance.
Yan
Originally posted by parag Chatterjee:
Hi ,
I have created a web application at the path
config/myDomain/appilications/<myWebApp>
I have created a war named myWeb.war at
config/myDomain/appilications
by using the command
jar cf myWebApp.war <myWebApp>

Using weblogic Admin Console I had deployed the war.
There is a file named index1.html in the path
<myWebApp> at deployments/web applications
I am typing
http://localhost:7001/index1.html at browser uri path
No File found error in given at the browser.
Can anybody help me how the war file will be successfully deployed and then contents of <myWebApp> will be visible on the browser.

[LIST]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic