• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Aprilaire HVAC 8825 Java Web App Problem

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First, I know nothing about Java programming, a bit about PC's and networking and am having big trouble with this App. The program dates back to about 2004-5. It stopped working after updating either IE or Java a number of years ago. At that time I was able to get it working on and old Dell Inspiron 8800 running the specs below: (I'm afraid if I don't find a solution and this notebook dies I will not be able to control the HVAC system anymore using a PC.)

W2K
IE 6.01
Java 1.5

I have been trying to recreate this configuration using virtual box but it just doesn't run. I tried finding VM software for transferring an actual machine to a virtual machine, using VirtualBox, Hyper-V and VMWare. I should have done it a few years ago. No current versions support W2K machines. Tried installing from scratch on VirtualBox but can't find a standalone installer for IE6 on any reputable sites.

I have a VirtualBox with WinXP, IE 6.02 and Java 1.5 but get the following errors:

Java Plug-in 1.5.0_03
Using JRE version 1.5.0_03 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\HVACUser


----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
p: reload proxy configuration
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

load: class CJavapadApplet.class not found.
java.lang.ClassNotFoundException: CJavapadApplet.class
at sun.applet.AppletClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed.
at sun.applet.AppletClassLoader.getBytes(Unknown Source)
at sun.applet.AppletClassLoader.access$100(Unknown Source)
at sun.applet.AppletClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
... 10 more




I have a VirtualBox with W2K, IE 5.0 and Java 1.5 but get the following errors:





#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d005579, pid=820, tid=908
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_03-b07 mixed mode, sharing)
# Problematic frame:
# C [awt.dll+0x5579]
#

--------------- T H R E A D ---------------

Current thread (0x041cf778): JavaThread "Thread-4" [_thread_in_native, id=908]

siginfo: ExceptionCode=0xc0000005, reading address 0x00007fff

Registers:
EAX=0x00007fff, EBX=0x047e4760, ECX=0x00000000, EDX=0x00000000
ESP=0x04bcf428, EBP=0xfffffffc, ESI=0x041cf834, EDI=0x6d11c5f8
EIP=0x6d005579, EFLAGS=0x00010246

Top of Stack: (sp=0x04bcf428)
0x04bcf428: 6d001d0e 04bcf48c ffffffff 041cf778
0x04bcf438: 2ab65ec8 04bcf5dc 2b3d4b40 041cba00
0x04bcf448: ffffffff ffffffff 00000030 047e4760
0x04bcf458: 04bcf4e4 6d6bdad8 04bcf48c 04bcf4b8
0x04bcf468: 00000004 00000004 00000015 00000019
0x04bcf478: 00000000 00000000 6d75b450 04bcf4e4
0x04bcf488: 6d6bdad8 00000004 00000004 00000015
0x04bcf498: 00000019 051dffac 00000001 00000014

Instructions: (pc=0x6d005579)
0x6d005569: ca c1 e8 03 8d 04 88 8b 4c 24 04 8b 51 24 33 c9
0x6d005579: 8a 0c 10 8b c1 c3 90 51 8b 44 24 08 8b 54 24 10


Stack: [0x04b90000,0x04bd0000), sp=0x04bcf428, free space=253k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [awt.dll+0x5579]

[error occurred during error reporting, step 120, id 0xc0000005]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j sun.java2d.loops.BlitBg.BlitBg(Lsun/java2d/SurfaceData;Lsun/java2d/SurfaceData;Ljava/awt/Composite;Lsun/java2d/pipe/Region;Ljava/awt/Color;IIIIII)V+0
j sun.java2d.pipe.DrawImage.blitSurfaceData(Lsun/java2d/SunGraphics2D;Lsun/java2d/pipe/Region;Lsun/java2d/SurfaceData;Lsun/java2d/SurfaceData;Lsun/java2d/loops/SurfaceType;
Lsun/java2d/loops/SurfaceType;IIIIIILjava/awt/Color;)V+138
j sun.java2d.pipe.DrawImage.renderImageCopy(Lsun/java2d/SunGraphics2D;Ljava/awt/Image;Ljava/awt/Color;IIIIII)Z+75
j sun.java2d.pipe.DrawImage.copyImage(Lsun/java2d/SunGraphics2D;Ljava/awt/Image;IILjava/awt/Color;)Z+45
j sun.java2d.pipe.DrawImage.copyImage(Lsun/java2d/SunGraphics2D;Ljava/awt/Image;IILjava/awt/Color;Ljava/awt/image/ImageObserver;)Z+15
j sun.java2d.SunGraphics2D.drawImage(Ljava/awt/Image;IILjava/awt/Color;Ljava/awt/image/ImageObserver;)Z+18
j sun.awt.image.ImageRepresentation.drawToBufImage(Ljava/awt/Graphics;Lsun/awt/image/ToolkitImage;IILjava/awt/Color;Ljava/awt/image/ImageObserver;)Z+152
j sun.java2d.pipe.DrawImage.copyImage(Lsun/java2d/SunGraphics2D;Ljava/awt/Image;IILjava/awt/Color;Ljava/awt/image/ImageObserver;)Z+56
j sun.java2d.SunGraphics2D.drawImage(Ljava/awt/Image;IILjava/awt/Color;Ljava/awt/image/ImageObserver;)Z+18
j sun.plugin.util.GrayBoxPanel.drawImage(Ljava/awt/Graphics;Ljava/awt/Image;II)V+9
j sun.plugin.util.GrayBoxPanel.paint(Ljava/awt/Graphics;)V+79
j sun.plugin.util.GrayBoxPanel.setImage(Ljava/awt/Image;)V+40
j sun.plugin.util.GrayBoxPanel.setError()V+18
j sun.plugin.util.GrayBoxPainter.paintGrayBox(Ljava/awt/Container;Ljava/awt/Graphics;)V+95
j sun.plugin.util.GrayBoxPainter.repaintGrayBox()V+12
j sun.plugin.util.GrayBoxPainter.showLoadingError()V+6
j sun.plugin.AppletViewer.showAppletException(Ljava/lang/Throwable;)V+43
j sun.applet.AppletPanel.runLoader()V+100
j sun.applet.AppletPanel.run()V+13
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
0x01e1ee08 JavaThread "TimerQueue" daemon [_thread_new, id=552]
0x04794e10 JavaThread "Image Fetcher 0" daemon [_thread_in_vm, id=280]
0x047c7008 JavaThread "AWT-EventQueue-2" [_thread_blocked, id=652]
0x01de6dd0 JavaThread "Keep-Alive-Timer" daemon [_thread_blocked, id=276]
0x041cbb18 JavaThread "TimerQueue" daemon [_thread_blocked, id=904]
=>0x041cf778 JavaThread "Thread-4" [_thread_in_native, id=908]
0x0470a058 JavaThread "thread applet-CJavapadApplet.class" [_thread_blocked, id=912]
0x041d67f0 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=900]
0x041b78d0 JavaThread "traceMsgQueueThread" daemon [_thread_blocked, id=892]
0x01e6e7c0 JavaThread "AWT-Windows" daemon [_thread_in_native, id=888]
0x01e6e398 JavaThread "AWT-Shutdown" [_thread_blocked, id=884]
0x041b27f8 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=880]
0x01e14900 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=424]
0x01e135c8 JavaThread "CompilerThread0" daemon [_thread_blocked, id=96]
0x01e128f0 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=720]
0x01e10c88 JavaThread "Finalizer" daemon [_thread_blocked, id=256]
0x01e0f7b0 JavaThread "Reference Handler" daemon [_thread_blocked, id=828]
0x00b5d280 JavaThread "main" [_thread_in_native, id=784]

Other Threads:
0x01ddc868 VMThread [id=516]
0x01e15b98 WatcherThread [id=876]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None

Heap
def new generation total 576K, used 182K [0x20ab0000, 0x20b50000, 0x21210000)
eden space 512K, 29% used [0x20ab0000, 0x20ad5ac8, 0x20b30000)
from space 64K, 49% used [0x20b40000, 0x20b47f10, 0x20b50000)
to space 64K, 0% used [0x20b30000, 0x20b30000, 0x20b40000)
tenured generation total 1408K, used 713K [0x21210000, 0x21370000, 0x26ab0000)
the space 1408K, 50% used [0x21210000, 0x212c2510, 0x212c2600, 0x21370000)
compacting perm gen total 8192K, used 1236K [0x26ab0000, 0x272b0000, 0x2aab0000)
the space 8192K, 15% used [0x26ab0000, 0x26be5398, 0x26be5400, 0x272b0000)
ro space 8192K, 62% used [0x2aab0000, 0x2afb8850, 0x2afb8a00, 0x2b2b0000)
rw space 12288K, 46% used [0x2b2b0000, 0x2b83ced8, 0x2b83d000, 0x2beb0000)

Dynamic libraries:
0x00400000 - 0x00412000 C:\Program Files\Internet Explorer\iexplore.exe
0x77f80000 - 0x77ff9000 C:\WINNT\System32\ntdll.dll
0x77e80000 - 0x77f36000 C:\WINNT\system32\KERNEL32.dll
0x77e10000 - 0x77e75000 C:\WINNT\system32\USER32.dll
0x77f40000 - 0x77f7c000 C:\WINNT\system32\GDI32.DLL
0x77c70000 - 0x77cba000 C:\WINNT\system32\SHLWAPI.dll
0x77db0000 - 0x77e0a000 C:\WINNT\system32\ADVAPI32.DLL
0x77d40000 - 0x77daf000 C:\WINNT\system32\RPCRT4.DLL
0x76c80000 - 0x76d90000 C:\WINNT\System32\shdocvw.dll
0x77b50000 - 0x77bda000 C:\WINNT\system32\COMCTL32.DLL
0x775a0000 - 0x777e0000 C:\WINNT\system32\SHELL32.DLL
0x77a50000 - 0x77b45000 C:\WINNT\system32\ole32.dll
0x76e10000 - 0x76ed8000 C:\WINNT\System32\BROWSEUI.dll
0x77cc0000 - 0x77d40000 C:\WINNT\System32\CLBCATQ.DLL
0x779b0000 - 0x77a45000 C:\WINNT\system32\OLEAUT32.DLL
0x78000000 - 0x78046000 C:\WINNT\system32\MSVCRT.DLL
0x76ee0000 - 0x76eeb000 C:\WINNT\System32\browselc.dll
0x77850000 - 0x7788c000 C:\WINNT\System32\cscui.dll
0x770c0000 - 0x770e3000 C:\WINNT\System32\CSCDLL.DLL
0x76b90000 - 0x76bfe000 C:\WINNT\system32\URLMON.DLL
0x77820000 - 0x77827000 C:\WINNT\system32\VERSION.DLL
0x759b0000 - 0x759b6000 C:\WINNT\system32\LZ32.DLL
0x76c00000 - 0x76c74000 C:\WINNT\system32\WININET.dll
0x76d90000 - 0x76de3000 C:\WINNT\system32\shdoclc.dll
0x75d50000 - 0x75dd2000 C:\WINNT\System32\mlang.dll
0x75050000 - 0x75058000 C:\WINNT\System32\wsock32.dll
0x75030000 - 0x75044000 C:\WINNT\System32\WS2_32.DLL
0x75020000 - 0x75028000 C:\WINNT\System32\WS2HELP.DLL
0x74fd0000 - 0x74fe1000 C:\WINNT\system32\msafd.dll
0x75010000 - 0x75017000 C:\WINNT\System32\wshtcpip.dll
0x774e0000 - 0x77512000 C:\WINNT\System32\RASAPI32.DLL
0x774c0000 - 0x774d1000 C:\WINNT\System32\RASMAN.DLL
0x77530000 - 0x77552000 C:\WINNT\System32\TAPI32.DLL
0x77830000 - 0x7783e000 C:\WINNT\System32\RTUTILS.DLL
0x75ab0000 - 0x75ab5000 C:\WINNT\System32\sensapi.dll
0x77c10000 - 0x77c6d000 C:\WINNT\System32\USERENV.DLL
0x75170000 - 0x751bf000 C:\WINNT\System32\netapi32.dll
0x77be0000 - 0x77bef000 C:\WINNT\System32\SECUR32.DLL
0x751c0000 - 0x751c6000 C:\WINNT\System32\NETRAP.DLL
0x75150000 - 0x7515f000 C:\WINNT\System32\SAMLIB.DLL
0x77950000 - 0x77979000 C:\WINNT\system32\WLDAP32.DLL
0x77980000 - 0x779a4000 C:\WINNT\System32\DNSAPI.DLL
0x77840000 - 0x7784c000 C:\WINNT\System32\rnr20.dll
0x777e0000 - 0x777e8000 C:\WINNT\System32\winrnr.dll
0x777f0000 - 0x777f5000 C:\WINNT\System32\rasadhlp.dll
0x77340000 - 0x77353000 C:\WINNT\System32\IPHLPAPI.DLL
0x77520000 - 0x77525000 C:\WINNT\System32\ICMP.DLL
0x77320000 - 0x77337000 C:\WINNT\System32\MPRAPI.DLL
0x773b0000 - 0x773de000 C:\WINNT\System32\ACTIVEDS.DLL
0x77380000 - 0x773a2000 C:\WINNT\System32\ADSLDPC.DLL
0x77890000 - 0x7791d000 C:\WINNT\System32\SETUPAPI.DLL
0x77360000 - 0x77379000 C:\WINNT\System32\DHCPCSVC.DLL
0x75af0000 - 0x75d33000 C:\WINNT\System32\mshtml.dll
0x75e60000 - 0x75e7a000 C:\WINNT\System32\IMM32.DLL
0x75de0000 - 0x75e57000 C:\WINNT\System32\jscript.dll
0x75ac0000 - 0x75ae8000 C:\WINNT\System32\MSLS31.DLL
0x75aa0000 - 0x75aa8000 C:\WINNT\System32\SHFOLDER.DLL
0x77570000 - 0x775a0000 C:\WINNT\System32\WINMM.DLL
0x77560000 - 0x77569000 C:\WINNT\System32\wdmaud.drv
0x77400000 - 0x77408000 C:\WINNT\System32\msacm32.drv
0x77410000 - 0x77423000 C:\WINNT\System32\MSACM32.dll
0x75d40000 - 0x75d46000 C:\WINNT\System32\msadp32.acm
0x6d590000 - 0x6d5a1000 C:\Program Files\Java\jre1.5.0_03\bin\npjpi150_03.dll
0x695e0000 - 0x69609000 C:\WINNT\System32\OLEPRO32.DLL
0x6d400000 - 0x6d417000 C:\Program Files\Java\jre1.5.0_03\bin\jpiexp32.dll
0x6d450000 - 0x6d468000 C:\Program Files\Java\jre1.5.0_03\bin\jpishare.dll
0x6d640000 - 0x6d7c6000 C:\PROGRA~1\Java\JRE15~1.0_0\bin\client\jvm.dll
0x6d280000 - 0x6d288000 C:\PROGRA~1\Java\JRE15~1.0_0\bin\hpi.dll
0x690a0000 - 0x690ab000 C:\WINNT\System32\PSAPI.DLL
0x6d610000 - 0x6d61c000 C:\PROGRA~1\Java\JRE15~1.0_0\bin\verify.dll
0x6d300000 - 0x6d31d000 C:\PROGRA~1\Java\JRE15~1.0_0\bin\java.dll
0x6d630000 - 0x6d63f000 C:\PROGRA~1\Java\JRE15~1.0_0\bin\zip.dll
0x6d000000 - 0x6d167000 C:\Program Files\Java\jre1.5.0_03\bin\awt.dll
0x77800000 - 0x7781d000 C:\WINNT\System32\WINSPOOL.DRV
0x72800000 - 0x72846000 C:\WINNT\System32\ddraw.dll
0x728a0000 - 0x728a6000 C:\WINNT\System32\DCIMAN32.dll
0x6d240000 - 0x6d27d000 C:\Program Files\Java\jre1.5.0_03\bin\fontmanager.dll
0x6d1f0000 - 0x6d203000 C:\Program Files\Java\jre1.5.0_03\bin\deploy.dll
0x77440000 - 0x774b8000 C:\WINNT\System32\CRYPT32.dll
0x77430000 - 0x77440000 C:\WINNT\System32\MSASN1.DLL
0x6d5d0000 - 0x6d5ed000 C:\Program Files\Java\jre1.5.0_03\bin\RegUtils.dll
0x770f0000 - 0x772ed000 C:\WINNT\System32\msi.dll
0x6d3e0000 - 0x6d3f4000 C:\Program Files\Java\jre1.5.0_03\bin\jpicom32.dll
0x6d4c0000 - 0x6d4d3000 C:\Program Files\Java\jre1.5.0_03\bin\net.dll
0x6d1c0000 - 0x6d1e3000 C:\Program Files\Java\jre1.5.0_03\bin\dcpr.dll
0x6b3d0000 - 0x6b40c000 C:\WINNT\System32\mshtmled.dll

VM Arguments:
jvm_args: -Xbootclasspath/a:C:\PROGRA~1\Java\JRE15~1.0_0\lib\deploy.jar;C:\PROGRA~1\Java\JRE15~1.0_0\lib\plugin.jar -Xmx96m -Djavaplugin.maxHeapSize=96m -Xverify:remote
-Djavaplugin.version=1.5.0_03 -Djavaplugin.nodotversion=150_03 -Dbrowser=sun.plugin -DtrustProxy=true -Dapplication.home=C:\PROGRA~1\Java\JRE15~1.0_0
-Djava.protocol.handler.pkgs=sun.plugin.net.protocol -Djavaplugin.vm.options=-Djava.class.path=C:\PROGRA~1\Java\JRE15~1.0_0\classes -Xbootclasspath/a:C:\PROGRA~1\Java\JRE15~1.0_0\lib\deploy.jar;C:\PROGRA~1\Java\JRE15~1.0_0\lib\plugin.jar
-Xmx96m -Djavaplugin.maxHeapSize=96m -Xverify:remote -Djavaplugin.version=1.5.0_03 -Djavaplugin.nodotversion=150_03
-Dbrowser=sun.plugin -DtrustProxy=true -Dapplication.home=C:\PROGRA~1\Java\JRE15~1.0_0 -Djava.protocol.handler.pkgs=sun.plugin.net.protocol vfprintf
java_command: <unknown>

Environment Variables:
PATH=C:\PROGRA~1\Java\JRE15~1.0_0\bin;C:\Program Files\Internet Explorer;;C:\Program Files\Internet Explorer\Connection Wizard;;C:\Program Files\Internet Explorer;;C:\WINNT\system32;
C:\WINNT;C:\WINNT\System32\Wbem;.
USERNAME=HVAC
OS=Windows_NT
PROCESSOR_IDENTIFIER=x86 Family 6 Model 14 Stepping 5, GenuineIntel


--------------- S Y S T E M ---------------

OS: Windows 2000 Build 2195

CPU:total 1 family 6, cmov, cx8, fxsr, mmx, sse, sse2, ht

Memory: 4k page, physical 1048048k(895444k free), swap 2523492k(2458676k free)

vm_info: Java HotSpot(TM) Client VM (1.5.0_03-b07) for windows-x86, built on Apr 13 2005 02:07:01 by "java_re" with MS VC++ 6.0







The company that produced the software/hardware solution no longer supports this version and now wants 3K for the latest. That would be the 3rd time in 10 years that I've had to upgrade because they dropped support. (Won't be buying their products again.)
Just looking for any suggestions or to let me know if this is just a lost cause.


Thanks for your consideration.

Jim
 
Bartender
Posts: 1210
25
Android Python PHP C++ Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to CodeRanch!

Perhaps we can start by trying to solve this HTTP connection failed error:

possibly due to some missed networking configuration.
Have you followed all the networking steps in their manual?
What are the IP addresses of your computer, VM and the HVAC device?
 
James Hoida
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The VM Machines, one is XP the other is W2K. Their IP's are both the same as they don't run simultaneously:

IP: 10.0.2.15
Sub: 255.255.255.0
GW: 10.0.22

The Aprilaire Controller is:
IP: 192.168.0.202
Sub: 255.255.255.0
GW: 192.168.0.1

It must be a VM thing as their both can ping other devices on the network including the Aprilaire controller. And the actually do both conntect to the controller's opening page. Shown below. And to another page that says it is loading the viewer. Eventually, on the XP machine it shows a small box with an "X" in the corner is gives the error towards the top of the page. On the W2K machine IE actually closes and creates at text doc with the error that is shown on the bottom half of the page. The behavior of the XP box is similar to that of any PC in the house that tries to connect to the controller. It will show the two pages as shown below and eventually show a box with and "X" in it and error out.
Image4.jpg
[Thumbnail for Image4.jpg]
Controller Opening Menu
Image1.jpg
[Thumbnail for Image1.jpg]
Trying to Load Viewer, then Erroring Out.
 
Karthik Shiraly
Bartender
Posts: 1210
25
Android Python PHP C++ Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The [x] space is where java tried to render the applet window by first trying to download it from server, but the download failed.
Since the page is opening fine, it means the HTTP server on controller and the network configurations of VMs are also ok.

There are a number of security barriers put by browsers on applet download and execution. It's possible something in the IE configuration is simply preventing download.
Unfortunately, I don't use Windows + IE much nowadays and don't remember the exact settings.
Can you check in IE settings, and change anything related to applets to "Allow" and reload the page?
I kind of remember it was under "Privacy" or "Advanced settings" or something like that.
There was also some security setting which had a scale like "very high" > "high" > "Medium" > "Low".
Try setting it to whatever's the lowest setting and reload.
 
James Hoida
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I changed the IP's of the VM XP and W2K machines. They are now:

The Aprilaire Controller is:
IP: 192.168.0.37 (for the XP and 38 for the W2K)
Sub: 255.255.255.0
GW: 192.168.0.1


The Aprilaire Controller is:
IP: 192.168.0.202
Sub: 255.255.255.0
GW: 192.168.0.1

I went in the the IE Options and changed all security setting to LOW and ENABLED or set to LOW and security options that involved running Java or Java applets. The W2k responded in the same way and just errored. The XP responded slightly differently and had an new error in the lower left hand corner as shown below. The error log from the Java Console was the same.



Image5.jpg
[Thumbnail for Image5.jpg]
New Error Shown In Lower Left Corner
 
Karthik Shiraly
Bartender
Posts: 1210
25
Android Python PHP C++ Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

The error log from the Java Console was the same.


Including the same "load: class CJavapadApplet.class not found." error line? Or is it a different class not found?

The network or security change does seem to have taken the execution a little further than before, so that's encouraging. I see this is now a trusted site zone instead of earlier Internet zone.

2 things I can think of:

1. Try clearing the IE cache and reopening from the home page, not the "/javapad.htm" page.
It's based on the possibility that "HomeLogicApplet notinited" is referring to some initialization that should possibly have executed on another applet on the home page.
If there's no improvement, try the next step.

2. Download the Java 1.5 JDK - not the JRE because that's already installed - but the JDK, and install it on the VM. Probably the XP VM can be used for further tests from now on.
Then C:\Program Files\Java\jdk1.5\bin will have a program appletviewer.exe
Open a cmd, cd to this directory, and run the command "appletviewer.exe http://192.168.0.202/javapad.htm".
See if the applet is launched, or does some error occur.
The idea here is to try to execute the applet from outside the browser's environment.
 
James Hoida
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Amazingly it ran. So the problem is with the browser as you pointed out. For my purposes am I able to just make a shortcut of that command line and run the problem that way and forget about the dang browser.

I really appreciate the help you given me.

Jim
 
James Hoida
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I meant run the applet using a shortcut.

Jim
 
Karthik Shiraly
Bartender
Posts: 1210
25
Android Python PHP C++ Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
TBH, I'm as amazed as you are that it ran outside the browser.
Anyway, glad it's working though probably Aprilaire is not as glad as us both
 
James Hoida
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had trouble with exact shortcut statement so I created a batch file to load it up. Works great. But still using the VM. I'm wondering if I copy the directories (Not actually install JAVA 1.5 JDK because of security reason) over to the machines I'm actually using rather then the VM. Could I use the same shortcut to run the program and not have any security issues on the machine.

Jim
 
Karthik Shiraly
Bartender
Posts: 1210
25
Android Python PHP C++ Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Applets are actually kind of outdated tech, and I really don't know how much attention Oracle is giving to their security aspects. The browsers certainly gave up on them long back.
In my opinion, you are better off operating it from inside the VM because it isolates the applet from your physical machine and rest of your network.

But if you are completely confident about firewalls and security of your entire network, you can try installing the latest JDK on the physical machine - that would be Java1.8 JDK - and see if the applet runs using 1.8's appletviewer.exe.
I don't think copying 1.5 JDK is a good idea, even if it works.
 
James Hoida
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It does work just to copy over the directory and run the appletviewer. I'll just have to decide if I want to run it in the VM or not. The Aprilaire Configurator doesn't work and errors out yet. I hadn't tried it until now. Hardly ever use the part of the program. Guess I'll put the Dell Inspiron on a nice dry shelf somewhere so I can use the configurator when I need it. What I'm able to do now is 99% of what I ever need to do. I really appreciate your time and effort in helping me get this thing running on another PC.

Thanks so much!
 
    Bookmark Topic Watch Topic
  • New Topic