This week's book giveaway is in the Jython/Python forum.
We're giving away four copies of Hands On Software Engineering with Python and have Brian Allbey on-line!
See this thread for details.
Win a copy of Hands On Software Engineering with Python this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Bear Bibeault
  • Knute Snortum
  • Liutauras Vilda
Sheriffs:
  • Tim Cooke
  • Devaka Cooray
  • Paul Clapham
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Ron McLeod
  • Ganesh Patekar
  • salvin francis
Bartenders:
  • Tim Holloway
  • Carey Brown
  • Stephan van Hulst

Updates disable Java Eclipse  RSS feed

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I get Java updates they disable Java. After the updates I get the following message when attempting to open Eclipse: "A JAVA RUNTIME ENVIRONMENT (JRE) or JAVA DEVELOPMENT KIT (JDk) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations: C:\Program Files\Java\jre1.8.0_65\bin" Java Eclipse works just fine until I get an update and then suddenly I can't the Eclipse program to start. I've checked the path noted in the error message and the files are there.

My only solution to this has been to do a complete uninstall / reinstall but eventually I get another update and it crashes again. I need to get out of this cycle.

I am running (please no laughter!) Windows Vista x64 - Eclipse Java Mars. I am a beginer and so far Java programming is great but getting this to run is a head banger.

Thanks in advance for any help you might offer.

 
Raymond Streker
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looking at other posts from years ago I see this might have something to do with an incorrect path. Unfortunately, I don't know how to check and edit the path. If you think this is the problem can you please provide some details (or a link) to how I might check and correct the path?
 
Ranch Hand
Posts: 310
18
Linux MS IE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try to change the C:\Program Files\Java\jre1.8.0_65\bin path in Eclipse to %JAVA_HOME%\bin. I am not familiar with Java on Windows, but I believe the updater should update the %JAVA_HOME% variable to the most recent directory where new Java is installed.
 
Raymond Streker
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your response. I can't get into Eclipse. Whenever I try to start it I get the error I reported above. Is there some way to edit the path without opening the software?
 
Andrew Polansky
Ranch Hand
Posts: 310
18
Linux MS IE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try to run Eclipse from command line like this:



C:\path\to\eclipse\ must be replaced with location where you have Eclipse installed (the folder with eclipse.exe file), of course
 
Sheriff
Posts: 23965
50
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I looked in the readme.html file which was in my Eclipse (Mars) installation and it mentioned that the JRE used to run Eclipse is normally found in your PATH environment variable. (Unless you override that behaviour as per Adam's suggestion.)

My PATH variable starts with "C:\ProgramData\Oracle\Java\javapath;" and when I looked there I found java.exe, javaw.exe, and javaws.exe, all of which were symlinks to the actual executables in my latest Java installation. So of course my Eclipse installation runs fine and doesn't have your problem.

I'm using Windows 7 (until one of these days I accept the popup offering me Windows 10) but you're using Vista. Perhaps Vista doesn't support symlinks and so Oracle is handling things (or mishandling them) differently? Anyway start by checking your PATH variable and see what kind of Java-related paths are in it.
 
Raymond Streker
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Adam: I tried running the command line and I got a "path can be found or doesn't exist" error. Tried it several different ways to no avail. Must admit I haven't typed in command on a command line for years but I don't think I could have screwed this up as I simply copied and pasted what you offered and then tried several different edits of your version.

Paul: I checked my path variable and discovered the exact same path you identified. I followed the path and found the same symlinks (i.e., java.exe, javaw.exe, and javaws.exe). I can't imagine my Java executables are any different from yours so maybe this really is a Windows' version (e.g., Vista) issue. I've sent a message to Oracle support so perhaps I will get a response and some enlightenment.

Meanwhile, if either of you have something else I can try please let me know. If I can't get this solved I guess I can uninstall/reinstall and simple refuse to accept all updates. Rather a poor plan but at least I get a working version of Eclipse that way.

Might be time to get a new PC and some current (supported) software! Oh, did I just justify a new PC? I think I did!

Thanks again.
 
Raymond Streker
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm close to getting this fixed. Turns out that the Java update changes the path to Java (from something like java1.8.0_65 to use of symlinks via \javapath) but Eclipse doesn't know this and the update doesn't change the Eclipse path. So, I went into the Eclipse *.ini file and changed the path it uses. Now, at least I can get Ecliple to start. My new challenge is that Eclipse no longer finds my old Java workspace. I assume that somehow the path to the workspace was changed with the update. If I can find the old workspace all I should need to do is modify that path. Have no idea how to do this. As I told Oracle, learning Java programming is going pretty well but getting the program to run consumes most of my effort. Someday, I will get back to learning Java.
 
Paul Clapham
Sheriff
Posts: 23965
50
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's strange... my eclipse.ini file doesn't have anything in it about the path to the Java executable. Neither does the config.ini in the configuration folder. I can't find any other likely-looking ini files anywhere under my eclipse folder either, so I can't guess what file you might have changed.

Elsewhere in this forum we tend to recommend to beginners that they start with a basic text editor and the command line, so that they can concentrate on learning Java without being distracted by learning the ins and outs of an IDE.
 
Raymond Streker
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm pasteing my Ecllipse.ini below. You can see it contains a path to Java (7th line from the bottom). That is the path that I edited so that it matches the path in the Windows path variables. After I did this I could start it but not use it because it (i.e., Eclipse) posted an error "unable to locate workspace".
Turns out that the workspace problem self-corrected after a PC restart. I now have a fully functional (well, I hope) version of Eclipse and Java. Yeah...I can finally return to learning programming. By the way, I understand and appreciate your comment about starting using a simple text editor vs. something like Eclipse. My choice sort of reflects my way of doing most everything which is to just jump right into the deep end. Almost drowned doing this as a kid but my dad saved me and it turned out to be a great bonding experience. Thanks again for your help. Hope this makes sense to you.

eclipse.ini
-startup
../../../.p2/pool/plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.library
../../../.p2/pool/plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.300.v20150602-1417
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-install
C:/Users/Ray/eclipse/java-mars/eclipse
-vm
C:\ProgramData\Oracle\Java\javapath
-vmargs
-Dosgi.requiredJavaVersion=1.7
-Xms256m
-Xmx1024m
-Doomph.update.url=http://download.eclipse.org/oomph/updates/milestone/latest
-Doomph.redirection.index.redirection=index:/->http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Enable the latest installed version of Java in the Java Control Panel. In the Java Control Panel, click on the Java tab. Click View to display the Java Runtime Environment Settings. Verify that the latest Java Runtime version is enabled by checking the Enabled box. Click OK to save settings.

Install Java Update version 8u141 Into Windows

Install Java Update version 8u141 Into Windows
 
What's gotten into you? Could it be this tiny ad?
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!