• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

how to configure hibernate 3.6 with wildfly 10  RSS feed

 
Greenhorn
Posts: 2
IntelliJ IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Since wildfly 3.x support is removed from default Wildfly 10, and hibernate 3.6 is compliant with JPA 2.1;
i already have the hibernate jars included in the app and also excluded the Wildfly provided hibernate using jboss-deployment-structure.xml

However, the application is failed either at JNDI stage. or some required jars are not available / conflicting

Getting this exception:
javax.persistence.PersistenceException: [PersistenceUnit: org.myapp] Unable to build EntityManagerFactory
 
Sheriff
Posts: 21745
102
Chrome Eclipse IDE Java Spring Ubuntu VI Editor Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch!

Neela Joy wrote:hibernate 3.6 is compliant with JPA 2.1


Can you quote your sources? Because according to this, Hibernate 4.3 was the first Hibernate version to be 2.1 compliant.

But why not go with the Hibernate version that comes with WildFly? It comes with Hibernate 5.0.7.Final (as found in modules/system/layers/base/org/hibernate/main), which is a lot more recent than 3.6. So just include Hibernate 5.0.7.Final as a provided dependency.
 
Neela Joy
Greenhorn
Posts: 2
IntelliJ IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oops, hibernate 3.6 is compliant with JPA2.0, not 2.1  

There are major changes in the hibernate API from 3 to 5 and that will require major refactoring of the source code...
So, need to find out a way to be able to deploy with Hibernate 3.6 if possible.

Using the default Hibernate 5; the application does not deploy as the Validation itself fails.

 
What are your superhero powers? Go ahead and try them on this tiny ad:
how do I do my own kindle-like thing - without amazon
https://coderanch.com/t/711421/engineering/kindle-amazon
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!