• Post Reply Bookmark Topic Watch Topic
  • New Topic

Do all Java Packages work with depreceated code warning when we upgrade from JDK 1.4 to JDK 1.6  RSS feed

 
Tanka Banerjee
Ranch Hand
Posts: 65
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Do all Java Packages work with deprecated code warning when we upgrade from JDK 1.4 to JDK 1.6 ?
Please let me know the Java Packages and Classes which would not work in JDK 1.4 to JDK 1.6 Upgrade.

Regards
Tanka Banerjee
 
Jesper de Jong
Java Cowboy
Sheriff
Posts: 16060
88
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sun and Oracle have always been extremely careful with backward compatibility, so your Java 1.4 program should work on Java 6 without any problems.

However, there might be minor incompatibilities, and it's also possible to write programs in Java that for example use internal APIs of the JDK, and that might not work on a newer Java version.

If you are upgrading a production environment, you should ofcourse first test it out to see if there are any issues, before doing the upgrade on the production system.
 
Campbell Ritchie
Marshal
Posts: 56570
172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You cannot recompile if you have used the word enum as an identifier, because that became a keyword in Java5; the old .class files shou‍ld still work.
Why are you trying to upgrade to Java6, which was obsolete several years ago? Use Java8. If you are unlucky, you may pick up a version of Java6 with one of the security problems.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!