Win a copy of Getting started with Java programming language this week in the Beginning Java forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

bcpg-jdk15on-1.52.jar problem using on wildfly 10.0.0.Final  RSS feed

 
das govender
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

When I try and used 1.52 on bouncing castle to do Pgp encryption it does not deploy if I try and use the one provided by wildfly 10.0.0.Final . I get a  java.lang.NoClassDefFoundError: org/bouncycastle/openpgp/PGPException

If I try and use the one in the ear i get error

2016-07-09 10:58:17,917 DEBUG [systemErrorLogger] (default task-9) *$#Caused by: java.lang.SecurityException: Cannot verify jar:vfs:/content/fnds-ear-1.0.0.ear/lib/bcprov-jdk15on-1.52.jar!/
2016-07-09 10:58:17,917 ERROR [stderr] (default task-9) Caused by: java.lang.SecurityException: Cannot verify jar:vfs:/content/fnds-ear-1.0.0.ear/lib/bcprov-jdk15on-1.52.jar!/

See full details at https://developer.jboss.org/message/959787

How do I use the in wildfly?

Thanks,
Daslan

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!