Win a copy of Programming with Types this week in the Angular and TypeScript forum
or The Design of Web APIs in the Web Services forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Knute Snortum
  • Henry Wong
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Joe Ess
  • salvin francis

Problem in starting Nodemanager in weblogic 8.1

 
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am facing one problem, when monitoring NodeManager.
I am using Weblogic 8.1
On browser it says
[[NodeManager:300033]Could not execute command ping on the node manager. Reason: weblogic.nodemanager.NodeManagerException: [CommandInvoker: Failed to send command: 'ping to server 'null' to NodeManager at host: '15.76.221.205:8002' with exception [Security:090504]Certificate chain received from nta21205.india.hp.com - 15.76.221.205 failed hostname verification check. Certificate contained nta21205 but check expected nta21205.india.hp.com. Please ensure that the NodeManager is active on the target machine].]
& on console
it says
<Feb 21, 2003 1:21:23 PM GMT+05:30> <Warning> <Security> <BEA-090482> <BAD_CERTI
FICATE alert was received from nta21205.india.hp.com - 15.76.221.205. Check the
peer to determine why it rejected the certificate chain (trusted CA configuratio
n, hostname verification). SSL debug tracing may be required to determine the ex
act reason the certificate was rejected.>
I am unable to get the error
please help
Thanx
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You must config SSL between nodemanager and weblogic server
http://dev2dev.bea.com.cn/bbs/school/guide/webser/20030730.html
 
Ranch Hand
Posts: 48
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jack,
We also got a similar error like 'failed hostname verification check. Certificate.......'. When we checked the registry.xml in $BEA_HOME$ the <host> tag was holding a different name than my machine name. So we re-installed the server again after which the <host> tag was holding a proper value and we are able to run NodeManger successfully. Please post ur solution if it is not the above mentioned one.
Karthik
 
Jack Nicholson
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanx Chao Wang, Karthik Prabu.
But I was able to do that without any SSL configuration !!
I just changed status of Host Verification to NONE.
& that worked for me.
As I am not doing this for any production environment, it is safe.
But in realtime production environment, hostname verification is required for security purposes.
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
-------------------- jack posted!
But I was able to do that without any SSL configuration !!
I just changed status of Host Verification to NONE.
& that worked for me.
As I am not doing this for any production environment, it is safe.
But in realtime production environment, hostname verification is required for security purposes.

Hi Jack, I have a question about that !
How i can change the Host verificacion to NONE, how I can force without SSL?
Thanks in advance!

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
http://e-docs.bea.com/wls/docs90/secmanage/ssl.html#1194397

and also
http://e-docs.bea.com/wls/docs90/ConsoleHelp/taskhelp/security/DisableHostNameVerification.html

you should start weblogic.Server with the property:
-Dweblogic.security.SSL.ignoreHostnameVerification=true

in the startWeblogic.sh or whatever you use to start...

pierre
 
Pierluigi Vernetto
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Pierluigi Vernetto wrote:http://e-docs.bea.com/wls/docs90/secmanage/ssl.html#1194397

and also
http://e-docs.bea.com/wls/docs90/ConsoleHelp/taskhelp/security/DisableHostNameVerification.html

you should start weblogic.Server with the property:
-Dweblogic.security.SSL.ignoreHostnameVerification=true

in the startWeblogic.sh or whatever you use to start...

in any case if you reall y desperate you can start the MS with the startManagedServer.sh <servername>, that should usually work...

Eventually try also
-Dweblogic.webservice.client.verbose=true
-Dweblogic.security.SSL.verbose=true
-Dssl.debug=true
-Dweblogic.StdoutDebugEnabled=true



pierre

 
Pierluigi Vernetto
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
oops sorry I am having some trouble editing messages, and there is not an option to delete a previous message (??)

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had a similar problem, check that the hostname and listen address are the same on the Node Manager. Note that if the hostname is fully qualified the listen address on the node manager should also be the same. Click on machines > machine name > node manager
 
and POOF! You're gone! But look, this tiny ad is still here:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!