• Post Reply Bookmark Topic Watch Topic
  • New Topic

trying to extract tweets using streaming api using java  RSS feed

 
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


why i am getting this error?
Exception in thread "main" java.lang.NoSuchMethodError: twitter4j.TwitterBaseImpl.<init>(Ltwitter4j/conf/Configuration;)V
at twitter4j.TwitterStreamImpl.<init>(TwitterStreamImpl.java:62)
at twitter4j.TwitterStreamFactory.getInstance(TwitterStreamFactory.java:71)
at SimpleStream.main(SimpleStream.java:28)
C:\Users\Acer\AppData\Local\NetBeans\Cache\8.1\executor-snippets\run.xml:53: Java returned: 1
 
Ranch Foreman
Posts: 3068
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What versions of the code do you have?
Where did you download them from?

Looking on github there's no constructor for TwitterBaseImpl that has only conf as a parameter.
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
twitter4j-4.0.4
Downloaded from http://twitter4j.org/en/index.html
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
in NetBeans IDE 8.1
 
Dave Tolls
Ranch Foreman
Posts: 3068
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you get hold of the source code and link it into your IDE so you can see exactly what code it thinks it's running?
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for your response..i am trying..
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
is there is any mistake in the way i am using streaming api in the above code?
 
Dave Tolls
Ranch Foreman
Posts: 3068
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The error you are getting implies that the TwitterStreamImpl class is calling a constructor in the TwitterBaseImpl class that doesn't exist.
That should not happen.
You don't have multiple versions in your classpath do you?
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i dont have multiple versions
 
Dave Tolls
Ranch Foreman
Posts: 3068
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, I'd suggest getting the code and seeing what's going on.
Possibly stepping through it in a debugger.
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for your time..
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the problem is in the twitter4j jar file..@Dave ..thanks....it solved now...
 
Dave Tolls
Ranch Foreman
Posts: 3068
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Could you post what the issue was?
 
surya preethaaa
Ranch Hand
Posts: 139
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i failed to add these two jar files
twitter4j-media-support-4.0.4.jar
twitter4j-stream-4.0.4.jar
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!