Win a copy of Practical SVG this week in the HTML/CSS/JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Tomcat 5 install to mirror old Tomcat 5 not finding xalan

 
Tommy Griffith
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello. This is really strange. I am trying to get an old Tomcat servlet (which works well) to end of life. Currently, it is running tomcat 5.0 with jre 1.5 on old machine. I have a new vm, installed the same jre and Tomcat using the same install files. I placed the same external jars like ant.jar, etc into common/lib.

I then deploy the very same war. But now, on the vm, I get exception...

Casued by: javalangnullpointerexception: Provider org.apache.xalan.processor.TransformerFactoryImpl not found...

I don't get this as I rebuilt the previous pc like four years ago and do't remember having to deal with this, especially with the very same external jars and war. Could somebody please help? I'm so frustrated. Thank you very much.
 
Tim Holloway
Bartender
Posts: 18419
60
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry about the delay.

You're working with a significantly outdated Tomcat running on a significantly dated JVM and I urge you to consider upgrading ASAP, as the expense of keeping up when things finally break for good rises pretty much exponentially over time.

I don't think that Xalan was included in the core JVM back in Java 5, although it has been so long I can't remember. You may have to manually include it in your WAR.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!