Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

request parameters received are null in weblogic 8.1

 
Lalita Sattavat
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The App server in use in Weblogic 8.1 and we encounter the following problem: After performing few activities on the server .. wait for 20 seconds and now click on any link on the jsp. All the request parameters are null. else otherwise the application works fine. Also the same behavior is not reproduceable on Weblogic 7.2

After disabling the keepalives for http in the weblogic server the problem got fixed.

Can somebody explain why this behavior. What is it that keepAlives does internally?
 
Rishi Tandon
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check the default session timeout set for the Web App.
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64970
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to the Weblogic forum.
 
andy armstrong
Ranch Hand
Posts: 154
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Change in servlet spec since 6.1..
"
Due to a change in the JSP specification, null request attributes now return the string "null" instead of an empty string. WebLogic <wiki.pl?WebLogic> Server versions since 6.1 contain a new flag in weblogic.xml called printNulls which is true by default, meaning that returning "null" is the default. Setting printNulls to false ensures that expressions with "null" results are printed as an empty string, not the string "null."
An example of configuring the printNulls element in weblogic.xml:

<weblogic-web-app>
<jsp-param>
<param-name>printNulls</param-name>
<param-value>false</param-value>
</jsp-param>
</weblogic-web-app>
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic