• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • Devaka Cooray
Saloon Keepers:
  • Ganesh Patekar
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • salvin francis
Bartenders:
  • Ron McLeod
  • Frits Walraven
  • Pete Letkeman

Problem using ant for deploying: Could not create task of type: wldeploy  RSS feed

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,

I have installed weblogic server 7.0 SP2 and I am trying to deploy an application through ant scripts. Following is a portion of the ant script which I am using:

<target name="deploy"> <wldeploy action="deploy" source="${dist}/ejb20_basic_statelessSession.jar" name="ejbapp" user="weblogic" password="weblogic" verbose="true" adminurl="t3://dscp00712:7001" debug="true" targets="cluster_elsewhere" /> </target>

Before I run this script, I run setWLSEnv.cmd, and it runs without giving an error and sets the classpath. After this, when I run the above and script, I get:

build.xml:93: Could not create task of type: wldeploy. Common solutions are to use taskdef to declare your task, or, if this is an optional task, to put the optional.jar in the lib directory of your ant installation (ANT_HOME).

I have also tried adding the following to my build.xml: <taskdef name="wldeploy" classname="weblogic.ant.taskdefs.management.WLDeploy"/>

However in this case I get an error: build.xml:12: taskdef class weblogic.ant.taskdefs.management.WLDeploy cannot be found

I am getting similar errors in case of wlcompile/wlserver, etc.

This seems to be some classpath problem, but since I am running setWLSEnv.cmd, I do not know what else needs to be put in the classpath.

Kindly help me regarding this.

Thanks a lot.
~Shan
 
Ranch Hand
Posts: 1209
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Guess, taskdef supports the classpath nested element.
Do declare the property weblogic.lib and make it point to weblogic lib folder.

I think the class that you are looking for is in weblogic.jar

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!