Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
Win a copy of Hands On Software Engineering with Python this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Bear Bibeault
  • Knute Snortum
  • Liutauras Vilda
Sheriffs:
  • Tim Cooke
  • Devaka Cooray
  • Paul Clapham
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Ron McLeod
  • Ganesh Patekar
  • salvin francis
Bartenders:
  • Tim Holloway
  • Carey Brown
  • Stephan van Hulst

Each request creating a new session  RSS feed

 
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I am working on a web application and using JBuilder X as IDE and Weblogic Server 7.0 as the application server. The problem I am facing is this:

When I compile and run the application from JBuilder, it works fine within the JBuilder environment but when i open a seperate browser window (IE or Netscape), it creates a new session for each request. My other team mates are using the same environment and their application seems to work fine either way.

I reinstalled both JBuilder and Weblogic Server but it didn't help.

Any help would be appreciated in this regard.

Thanks
Amit.
 
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

check if your browser is configured to accept cookies. http session objects use cookies to maintain session state so it's required that the client browser accpept cookies to work correctly. If you have a requirement that you have to maintain user information even when the client has configured it's browser to not accept cookies you can user url rewriting but it has some performance costs thougth...
 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you can try by deleting all offline contents and cookies.You can do this by using tools internet option in IE
 
A lot of people cry when they cut onions. The trick is not to form an emotional bond. This tiny ad told me:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!