Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

eclipse java  RSS feed

 
Joe Parkin
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I try to make a new project, click in the menu on file/new/ java project. Then a window opens up , I enter the name and click on finish but it doesn´t open. It s somewhere but I cannot start to code
 
Campbell Ritchie
Marshal
Posts: 55698
163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch

I shall move you to our IDEs forum.
Can you go into the workspace folder? There shou‍ld be a workspace folder somewhere in your computer, probably about the same level as MyDocuments; have a look in that and see whether there is a folder corresponding to the name of your project. Also try to open a project; does that show anything.
 
Henry Wong
author
Sheriff
Posts: 23283
125
C++ Chrome Eclipse IDE Firefox Browser Java jQuery Linux VI Editor Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

After you create a new project, you should see the project on the left -- assuming you have the package explorer there.  You can't start coding yet...

Next, optional, but a good idea, right click on the project, and add a (new) package(s) name. Next, right click on the package, and add a (new) class. At that point, your editor should have some template code, for that class in that package.

Henry 
 
Joe Parkin
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don t have a package explorer. I go to workspace folder there I have some file or subfolder like bin , classpath, but the problem is that eclipse doesn` t open a new project. When I go to new project a type in the same main class or project name it says the project already exists. But why I can`t I cannot code inside it. The other thing is eclipse shows an error  "workspace cannot be found. Still it writes a new subfolder in workspace.
When I click on project "open project " is not available.
 
Campbell Ritchie
Marshal
Posts: 55698
163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There should be options on Eclipse to see the package explorer: look under the Window menu for the Show View item and make sure package explorer is shown as visible. If not, go to other and add it.
 
Campbell Ritchie
Marshal
Posts: 55698
163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You probably want project&#nbsp;explorer rather than package explorer.
 
Joe Parkin
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you I try that
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!