• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

weblogic datasource defaultAutocommit Not working  RSS feed

 
Ranch Hand
Posts: 147
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am using weblogic 12c version and have created a data source in weblogic console. It is non XA data source. In connection pool properties setting i have provided defaultAutoCommit = false.

In the application i am using EJB transactions with toplink. Problem is that in one transaction, there are 5 insert statements and when i view database report, we found that there are 5 commit happens for one transaction which is not the desired behaviour. Using EJB transaction management, there should be one commit for all 5 transactions.

On further verification, we found that when toplink executes insert statement, weblogic is committing it. Because of this one 5 commit is happening. even if after providing defaultAutoCommit = false in connection pool properties, it is behaving the same.

Please provide your valuable suggestions.

Regards,
Sunil
 
It's weird that we cook bacon and bake cookies. Eat this tiny ad:
how do I do my own kindle-like thing - without amazon
https://coderanch.com/t/711421/engineering/kindle-amazon
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!