Win a copy of Murach's Java Programming this week in the Beginning Java forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Tomcat starts but doesn't reply  RSS feed

 
Tobia Scapin
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear all,
I'm working with Apache Tomcat/8.0.14 on Ubuntu server 15.04.
I have a Spring application deployed as ROOT, when I start tomcat service I saw all logs and the startup and context initializer seems to work.
But... it doesn't reply to HTTP request for many (15-20) minutes, after this time, it starts to reply. I don't see errors in the catalina log.

I checked with netstat and the connection pool is opened, the HTTP connections are not refused but they reach the timeout time.

What should I check? The same application in a windows tomcat8 enviroment works without problem.
 
Tim Holloway
Saloon Keeper
Posts: 18631
69
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First check your system load. If you're low on virtual memory and it's thrashing or CPU is all booked up, then naturally it will be slow.

Following that, look at how the application starts up. I once worked with an app that loaded half a database in RAM when it first came up.
 
argol diomolpol
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can use
This command with print all Threads in application. Make request and if you see that tomcat is not returning make a couple Thread Dumps. Then search for your application package name eq(com.awsome.app) if you see the same method in a couple of Thread dumps it maybe your slow part.

 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!