Bookmark Topic Watch Topic
  • New Topic

how to open msword file in weblogic

 
saleem javeed
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Report post to moderator
Hi,

I have recently started using weblogic, i have one application running in tomcat where i can view doc file, if i am uploading the same application in weblogic 8.1, it is not opening in doc format.
In tomcat i can set mime-type in conf folder using the given below

<mime-mapping>
<extension>doc</extension>
<mime-type>application/msword</mime-type>
</mime-mapping>


Can anybody help me how to set in weblogic 8.1. It will be great help for me.

thanks in advance

saleem

 
Senthil B Kumar
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
  • Report post to moderator
<mime-mapping>
<extension>doc</extension>
<mime-type>application/msword</mime-type>
</mime-mapping>

add the above entry to your WEB.XML
 
saleem javeed
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Report post to moderator
Hi Senthil,

Which web.xml i have to set, the one in my application.

i put in my application web.xml still it is not showing.


can u help me

thanks
saleem
 
Senthil B Kumar
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
  • Report post to moderator
an application will have a web.xml in it. This entry has to be put into that only.

If your browser doesnt has the plugin to open the word files, that may also be a problem.

What is exactly happening, when you try to open ?
 
Varun Kumar Gupta
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Report post to moderator
I have some links on a JSP page (application hosted on weblogic) which point to word documents/.PPT. When i click on the links, they should open up the file download dialog of windows (save to disk/open from current location). Instead, it shows up junk in a new window.

In my Jsp page I have used window.open function, this functinality is working fine on other server like Websphere and Tomcat but getting issue in weblogic server. Is there having any setting at Weblogic server end. Please help me, i ma facing this issue since long time..

In web.xml where I to made the changes, either in weblogic web.xml or in my application web.xml, I have tried both things but not able to resolve it.
 
Devaka Cooray
Marshal
Pie
Posts: 4879
402
Chrome Eclipse IDE Google App Engine IntelliJ IDE jQuery Postgres Database Tomcat Server
  • Mark post as helpful
  • send pies
  • Report post to moderator
Varun, please click the button and start a new topic for your question. Please don't append your own questions on the topics started by others. I'm locking this one.
 
    Bookmark Topic Watch Topic
  • New Topic