• Post Reply Bookmark Topic Watch Topic
  • New Topic

Eclipse “New Spring Legacy Project” wizard templates are outdated  RSS feed

 
Zahro Alfelpha
Ranch Hand
Posts: 67
1
Java Linux Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First of all it's weird to me that they even call it "Legacy" projects. So because it isn't Spring Boot it's legacy? Whatever. Anyways, The templates for Spring MVC seem to be terribly outdated. Choosing a new Spring MVC Project results in a Spring 3.2.2 project using Java 5. It says the url for the template is http://dist.springsource.com/release/STS/help/org.springframework.templates.mvc-3.2.2.zip. I can't seem to find the url to use a more up to date template. Can anyone point me in the right direction? (and no I don't mean a link to download IntelliJ lol). I am using Eclipse Neon 3.
 
Tim Cooke
Marshal
Posts: 3568
174
Clojure IntelliJ IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This question is more about Eclipse that Spring so I've added it to the IDE forum.

Sometimes these plugin tools are written and never updated again. Probably a question for the Eclipse team, or whoever wrote the template plugin you're using. If you do ask them, let us know what they say.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!