• Post Reply Bookmark Topic Watch Topic
  • New Topic

Can't telnet to localhost with putty  RSS feed

 
Ilya Zhavoronkov
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello!
I have tomcat 8.5.15 installed on windows 10.
With default windows telnet I can simply connect to localhost via telnet.
But putty crashes on trying to do the same thing.
Any suggestions?
 
Ron McLeod
Saloon Keeper
Posts: 1564
222
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you say crashes, do you mean PuTTy closes immeadiately after making a connection?
 
Ron McLeod
Saloon Keeper
Posts: 1564
222
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
...and welcome to the Ranch 
 
Ilya Zhavoronkov
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ron McLeod wrote:When you say crashes, do you mean PuTTy closes immeadiately after making a connection?


correct
 
Tim Holloway
Bartender
Posts: 18663
71
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And when you say "telnet", do you mean actual telnet or do you mean ssh?

Because they are 2 very different protocols. The telnet protocol is plain text, ssh is encrypted. I've never done telnet with PuTTY, only ssh.
 
Ron McLeod
Saloon Keeper
Posts: 1564
222
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maybe the server you connecting is by-chance sending some character sequences which PuTTy sees as a TELNET protocol error and closes the session.

Try using a connection type of Raw instead of Telnet and see if it stays connected.
 
Ilya Zhavoronkov
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ron McLeod wrote:Maybe the server you connecting is by-chance sending some character sequences which PuTTy sees as a TELNET protocol error and closes the session.

Try using a connection type of Raw instead of Telnet and see if it stays connected.


RAW helped, thanks!
 
Ilya Zhavoronkov
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tim Holloway wrote:And when you say "telnet", do you mean actual telnet or do you mean ssh?

Because they are 2 very different protocols. The telnet protocol is plain text, ssh is encrypted. I've never done telnet with PuTTY, only ssh.


both shh and telnet doesn't work for unknown reason
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!