• Post Reply Bookmark Topic Watch Topic
  • New Topic

JVMCFRE003 bad major version; class=com/fasterxml/jackson/databind/ObjectMapper, offset=6  RSS feed

 
murali jackson
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am trying to a program, but it throws the below error in console.



Before posting it here, I have googled about this error and got several related post. Most of the post advised to change the compiler and JRE settings in RAD to 1.6 .
I did that but it keep throwing the same error. I tried running Java -version command to see what JRE i have and it shows the below output.



Here is my java class for reference. Please advise on how to fix this error.


 
Jesper de Jong
Java Cowboy
Sheriff
Posts: 16060
88
Android IntelliJ IDE Java Scala Spring
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This error means that the library you are using (Jackson, a library for parsing JSON) is written for a newer version of Java than what you are using.

You are using Java 6, which is too old for the version of Jackson that you are using.

You'll need to find an older version of Jackson that is compatible with Java 6, or upgrade to a newer version of Java - the current version is Java 8, and Java 9 is coming later this year. Java 6 is quite old and unsupported, so you shouldn't use it anymore unless you really have to.

As far as I could find, Jackson 2.7 and newer require at least Java 7. You'll need to get a version of Jackson older than version 2.7 if you really need to use Java 6.
 
murali jackson
Ranch Hand
Posts: 55
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jesper de Jong wrote:This error means that the library you are using (Jackson, a library for parsing JSON) is written for a newer version of Java than what you are using.

You are using Java 6, which is too old for the version of Jackson that you are using.

You'll need to find an older version of Jackson that is compatible with Java 6, or upgrade to a newer version of Java - the current version is Java 8, and Java 9 is coming later this year. Java 6 is quite old and unsupported, so you shouldn't use it anymore unless you really have to.

As far as I could find, Jackson 2.7 and newer require at least Java 7. You'll need to get a version of Jackson older than version 2.7 if you really need to use Java 6.


Thanks Jong !!!
I have changed to older version of Jar and now its working !!!

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!