Win a 3 month subscription to Marco Behler Videos this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Can't setup Wildfly 10 as a Service on Ubuntu 16.04  RSS feed

 
Al Koch
Ranch Hand
Posts: 49
Eclipse IDE Firefox Browser Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have Wildfly 10 installed and running successfully on Ubuntu 16.04.  (This is on an AWS instance running Ubuntu but I don't think that is an issue).  I need to get this running as a service.  I have found a variety of books and URLs that describe how to do this but they all are for an earlier version of Wildfly and/or an earlier version of Ubuntu and as a result none of them is correct for the current server and OS combination.
I finally found https://dennis.gesker.com/2016/02/09/wildfly-10-on-ubuntu-15-10/ which seems to come close to working.  I already had Wildfly installed so I picked up in the instructions where we "Change ownership of directory and symbolic link to wildfly:"  The problem is as follows:

wildflyuser@ip-172-31-27-23:/etc/init.d? sudo update-rc.d wildfly defaults
wildflyuser@ip-172-31-27-23:/etc/init.d? service wildfly start
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'wildfly.service'.
Multiple identities can be used for authentication:
1.  Ubuntu (ubuntu)
2.  ,,, (wildflyuser)
Choose identity to authenticate as (1-2): 2
Password:
==== AUTHENTICATION COMPLETE ===
Job for wildfly.service failed because the control process exited with error code. See "systemctl status wildfly.service" and "journalctl -xe" for details.

I tried the suggested commands in the last line to see more detail but:
wildflyuser@ip-172-31-27-23:/etc/init.d? systemctl status wildfly.service
? wildfly.service - LSB: WildFly Application Server
   Loaded: loaded (/etc/init.d/wildfly; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-07-31 15:34:08 UTC; 20s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 17041 ExecStart=/etc/init.d/wildfly start (code=exited, status=1/FAILURE)


Can anyone tell me:
1) What's going wrong here, OR
2) Point me to a procedure that will let em get Wildfly running as a service?

Thank you.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!