This week's book giveaway is in the Performance forum.
We're giving away four copies of The Java Performance Companion and have Charlie Hunt, Monica Beckwith, Poonam Parhar, & Bengt Rutisson on-line!
See this thread for details.
Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem in upgrading wl6 to wl 8.1

 
Tausif Khanooni
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys,
I am facing problem in upgrading the weblogic 6 to weblogic 8.1. I am running my application running on linux. the steps i followed are:

1. created link to point where my application (file structure) located at WL_HOME/config/<mydomain> this folder points to the actual application. believe me guys this is not a problem i guess.

2. updated my setEnv.sh and startWeblogic.sh scripts and pointed the weblogic.jar etc correctly.

3. made slight changes in weblogic.xml file these changes are:
removed the old entry and added these lines:
<Security Name="mydomain" Realm="mysecurity"/>
<Realm Name="mysecurity" FileRealm="myrealm"/>
<FileRealm Name="myrealm"/>

4. tried to start the WL Server, resulting these eorrors:

***************************************************************************
The WebLogic Server did not start up properly.
Exception raised: 'weblogic.management.configuration.ConfigurationException: The MBean wlsadmin:Name=wlsadmin,Type=Security had an unresolved reference for the attribute Realm the mbean wl_default_realm'
Reason: weblogic.management.configuration.ConfigurationException: The MBean wlsadmin:Name=wlsadmin,Type=Security had an unresolved reference for the attribute Realm to the mbean_default_realm
***************************************************************************


does anybody has any idea?
 
Chris Mathews
Ranch Hand
Posts: 2712
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you create a new domain for WLS 8.1? I wouldn't even consider modifying an existing WLS 6.1 domain and expect it to work...
 
Deepak Dew
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The best way is to create a new domain in weblogic81 and move all the codes from weblogic6 to version 8.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic