Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Resends the same request after 5 minutes

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi ppl,

I have an application, which uses iplanet and weblogic.I send one request which takes more than 5 minutes for processing that.

Since, it takes more than 5 minutes, the iplanet is again resending the
same request. Is there any way to make iplanet not to send another request
after 5 minutes.

Please suggest on this.

Thanks,
shek
 
Ranch Hand
Posts: 2713
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
By default, WLIOTimeoutSecs for the WebLogic Plugin (which you are using for IPlanet) is configured to 300 seconds. After 300 seconds (5 minutes) the plugin will interpret the request as being "hung" and try to send another. This is what is causing your multiple requests.

You options are...

1) Up the WLIOTimeoutSecs value.
2) Change the paradigm you are using so that a request doesn't take 5 minutes. This is generally a bad user experience anyways. For example, you could execute the logic asynchronously and return immediately to the user with a message to either check back later for results or email them with a link to the results.
 
shekoo shek
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I tried upping the value for WLIOTimeoutSecs but its still retries the request after 5mins (300 sec).

Here is the entry in obj.conf.

<Object name="weblogic" ppath="*/apps/*">
Service method="(GET|HEAD|POST|PUT)" fn="wl_proxy" DebugConfigInfo="ON" WLLogFile="C:/iPlanet/Servers/localhost/logs/wlproxycpr.log" Debug="ON" WebLogicHost=localhost WebLogicPort=7001 PathTrim="/apps" WLIOTimeoutSecs="1800"
</Object>

I am using Iplanet 6.0 and weblogic8.1

any kind of suggestion is appreciated.
 
shekoo shek
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
After looking at some suggestions on line we tried to add Idempotent="OFF"

here is how the obj element looks

<Object name="weblogic" ppath="*/apps/*">
Service method="(GET|HEAD|POST|PUT)" fn="wl_proxy" DebugConfigInfo="ON" WLLogFile="C:/iPlanet/Servers/localhost/logs/wlproxycpr.log" Debug="ON" WebLogicHost=localhost WebLogicPort=7001 PathTrim="/apps" Idempotent="OFF"
</Object>

Now the retry has stopped but the browser shows the following error.

Message from the NSAPI plugin:

Internal Server failure, NSAPI plugin. Cannot continue.

Any ipnputs is appreciated
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi

We too were facing the same problem with iPlanet. We were able to resolve it by using 'HungServerRecoverSecs'(old name for WLIOTimeoutSecs) instead of WLIOTimeoutSecs
 
Whatever. Here's a tiny ad:
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic